http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8034 --- Comment #6 from Srdjan Jankovic <srdjan@catalyst.net.nz> --- (In reply to comment #5)
QA comments:
* I don't understand the need/use of + my $userenv_branch = $userenv ? $userenv->{"branch"} : undef; why don't you use $userenv->{"branch"} ?
I was not sure that $userenv is guaranteed to be there.
* the sub + =head2 get_user_printer must not be in C4/Auth.pm, but in C4/Print.pm (not a perfect option)
/() should not be in C4/Print.pm, because Print.pm is doing printing, not printer queue selection. get_user_printer() is a matter of session, that's why I placed it there (same as library selection).
or in Koha:: namespace (in the hackfest currently running, I've proposed a time to discuss of naming convention/organisation for Koha:: namespace) * same comment for sub GetPrinterDetails {, should not be in C4/Koha.pm
Other than this, the code looks OK (haven't tested it yet)
I can move GetPrinter* functions to C4/Print.pm. I'd probably prefer to have C4/Printer.pm, but C4/Print.pm would do. -- You are receiving this mail because: You are watching all bug changes.