https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21780 Bug ID: 21780 Summary: LostItem should be called from ModItem Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org Whilst QAing bug 21754 and bug 20884 I realised that the functionality related to losing an item is not very well encapsulated. Currently LostItem is called in various places following a ModItem call. We should move the call to LostItem inside of ModItem to lower the risk of LostItem not being applied after a ModItem call has been made. This would be a good first step towards a more thorough refactoring of this area of the codebase and the move to the Koha:: namespace. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.