https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31150 --- Comment #12 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Martin Renvoize from comment #10)
DOI we really want to have contradictory guidelines for this.. it's already annoying having API fields named differently in the database.. here your basically suggesting enforcing that.. DB fields must not match API field.. that really doesn't make sense to me. I honestly don't remember the discussion around _on vas _date.. but I do remember we all agreed on one and put it in a guideline to prevent a debate every time we came to adding another API..
We never agreed on a convention for DB column names, hence this bug report. The guideline is for the REST API. """ Where a field contains a 'date' it should be consistently named *_date as opposed to date_* and it should always return a full datetime. """ As stated before, the problem is that a _date suffix is confusing for other datatypes IMO. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.