https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32545 Bug ID: 32545 Summary: For naming consistency, PatronSelfModificationMandatoryField should be PatronSelfModificationBorrowerMandatoryField Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: System Administration Assignee: koha-bugs@lists.koha-community.org Reporter: andrewfh@dubcolib.org QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com The syspref PatronSelfModificationMandatoryField should be PatronSelfModificationBorrowerMandatoryField It's part of a set of sysprefs with an existing naming convention. For the staff interface, we have BorrowerUnwantedField and BorrowerManadatoryField. We prepend "PatronSelfRegistration" onto those names for PatronSelfRegistrationBorrowerMandatoryField and PatronSelfRegistrationBorrowerUnwantedField. We prepend "PatronSelfModification" for PatronSelfModificationBorrowerUnwantedField. Making PatronSelfModificationMandatoryField break the established convention causes confusion (even if PatronSelfModificationBorrowerMandatoryField is goofily long). -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.