http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12933 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #23 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- (In reply to Kyle M Hall from comment #16)
(In reply to Jonathan Druart from comment #15)
I agree with Joubu that I don't like having a second GetOverdues added to the code.. it's not DRY.. if you really want to be able to access the function from C4::Members rather than directly from C4::Overdues, then it should be a sugar function that refers to C4::Overdues in my mind, else it's confusing to future people working on the code. If it does perform a different function.. then surely that should be made clear by naming it something completely different, or enahcning the C4::Overdues function with the required extras and a filter perhaps? Just my thoughts -- You are receiving this mail because: You are watching all bug changes.