https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25690 --- Comment #27 from Joonas Kylmälä <joonas.kylmala@helsinki.fi> --- (In reply to Kyle M Hall from comment #25)
Comment on attachment 117064 [details] [review] Bug 25690: Remove duplicated logic in SIP2 checkouts
Review of attachment 117064 [details] [review]: -----------------------------------------------------------------
::: C4/SIP/ILS/Transaction/Checkout.pm @@ +53,4 @@
my $patron = Koha::Patrons->find($self->{patron}->{borrowernumber}); my $overridden_duedate; # usually passed as undef to AddIssue $debug and warn "do_checkout borrower: . " . $patron->borrowernumber; + my ($issuingimpossible, $needsconfirmation) = _can_we_issue($patron, $barcode, 0);
Can you explain why this is hard coded to 0 now?
The logic is moved now to
$confirmation eq 'RESERVED' and C4::Context->preference("AllowItemsOnHoldCheckoutSIP")
and
$confirmation eq 'RESERVED' and !C4::Context->preference("AllowItemsOnHoldCheckoutSIP")
checks. There was never need to do the skipping in the core module. The 0 can be refactored out but I didn't do so here because the patch series got already so long. -- You are receiving this mail because: You are watching all bug changes.