https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15895 --- Comment #13 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Srdjan Jankovic from comment #12)
I know this has been signed off, but I think there's no such thing as "an Account", therefore pay() should go to Koha::Patron. In that case, rather than letting surrounding code look for account lines, it can support passing criteria, and make a accountlines() call to get the lines.
I don't think having the pay method be part of Koha::Patron makes any more sense than this. If it were to be moved anywhere, I think maybe moving it to Koha::AccountLines would more appropriate if anything. I'd be happy to move the method to a difference class after we've got these pushed to master. The dependency chain for this is complex and I would prefer not to introduce such changes until the tail end of the patch series. -- You are receiving this mail because: You are watching all bug changes.