https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33242 --- Comment #12 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Marcel de Rooy from comment #11)
(In reply to Jonathan Druart from comment #10)
I was going to PQA until I saw bug 33029, which gives us more flexibility. Not sure we need both personally.
Yes we looked at that. Kyle, Nick and I concluded that both go fine together. See description too, saying this:
Compare the 33029 approach [% KohaDates.datetime_from_string(checkout.issuedate).add( days => 3) | $KohaDates %] with the approch of this report [% checkout.issuedate | $KohaDates add_days => 3 %]
The latter notation is definitely shorter and prettier in my use case and does only need a few lines more.
Yes, more code to maintain, and the parsing here looks hacky to me, for less flexibility. Note that I didn't FQA but I am not the one who is going to PQA this ;) -- You are receiving this mail because: You are watching all bug changes.