17 Dec
2018
17 Dec
'18
10:52 a.m.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21065 --- Comment #19 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Martin Renvoize from comment #18)
I think we should start using a more descriptive naming scheme for foreign keys.. instead of table_ibfk_int (where int is a running number) we should make them more descriptive and have table1_fk_table2.. or {tablename}_{columnname(s)}_{suffix} (as per postgres defaults perhaps).. that would mean in this case we could check for the old _1 key before deleting it and check for the new _table2 constraint before creating it.
Makes sense for me. -- You are receiving this mail because: You are watching all bug changes.