http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10262 --- Comment #14 from Galen Charlton <gmcharlt@gmail.com> --- (In reply to comment #13)
Yes, that is rather ugly. _GetCircControlBranch does a lot of under the hood logic, far more than the new statement, but I think the results would be this same. So we can unify that. [snip]
- the fact that the patch couldn't use _GetCircControlBranch and is overloading the PickupLibrary value for CircControl, while consistent with fines.pl, is IMO stretching the CircControl syspref a bit too far.
Should we make fines.pl use _GetCircControlBranch as well?
First we'll have to figure out what we want _GetCircControlBranch to do. However, it might be as simple as passing it an optional issues hash so that it handle the special PickupLibrary case for loans.
- the patch include whitespace changes that obscured its purpose
My bad, I have a perltidy addiction. I just can't help myself ; )
That addiction is best indulged in separate patches that follow the substantive ones. -- You are receiving this mail because: You are watching all bug changes.