https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 --- Comment #195 from David Gustafsson <glasklas@gmail.com> --- Ok, thanks for the feedback! I think I fixed most things except: (In reply to Joonas Kylmälä from comment #188)
Comment on attachment 78690 [details] [review] Bug 19893 - Alternative optimized indexing for Elasticsearch
Review of attachment 78690 [details] [review]: -----------------------------------------------------------------
::: Koha/SearchEngine/Elasticsearch.pm @@ +333,5 @@
+ } + push @{$record_document->{$target}}, $_data; + } + } + foreach my $record (@{$records}) {
Instead of stacking multiple for loops here, we can move this block to its own function, maybe called marc_record_to_document. This should make it easier to understand the code as the for loop would be then named and code doesn't go horizontally off the screen, right?
I don't get the line numbers to match up, but perhaps I'm using a different base. I don't recognize this code in my current branch. -- You are receiving this mail because: You are watching all bug changes.