https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26890 --- Comment #15 from Mark Hofstetter <koha@trust-box.at> --- just slept over it, and maybe I'm getting an idea about what feels wrong. The system is very explicit now, meaning you need a lot of code in specific places to use a plugin excactly "there" I think a plugin system needs to be more implicit eg all cgi scripts should use the same plugin hook(s) (with the name of the script as a config parameter whether the plugin should actually run) eg: plugin parameter rewrite add a parameter to all queries, or whenever a ISBN appears do a transformation + maybe could be doable by simply subclassing CGI + or better an more generalised, derive all cgi scripts from a common base class, wrap the code in a sub run {} and everthing becomes possible, this may sound huge but should be in fact only a few lines per script as I've said just thinking loud(ly) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.