https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33364 --- Comment #16 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Aleisha Amohia from comment #15)
(In reply to Marcel de Rooy from comment #14)
@@ -1227,7 +1227,7 @@ sub has_pending_recall { return Koha::Recalls->search( { item_id => $self->itemnumber, - status => 'waiting', + status => [ 'waiting', 'in_transit' ],
Could you please explain why a recall is named pending, when it is waiting or in transit? Looks like inconsistent naming? Since a pending hold is a hold that is NOT waiting or in transit. Actually it also looks at tmp_holdsqueue (and that table depends on a pref too).
Because at this stage, the item has already been allocated to the recall. It is in transit to the library where it would be picked up by the patron who requested it.
I think that's what Marcel meant, that "pending" for holds means NOT allocated. I haven't verified that in code, but I believe in the interface that is indeed the case. -- You are receiving this mail because: You are watching all bug changes.