https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16631 --- Comment #142 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- (In reply to Casey Conlin - mattermost @Casey246 from comment #141)
One more thing, this time on renaming "branch" to "library".
Would that change be mostly for user-facing UI? Like: 1. “My branch reports” to “My library reports” 2. “Show my branch reports” to “Show my library reports” 3. Any other visible “branch” wording introduced by this patch
Or would we want to rename things that happen "behind the scenes" in the code, too? Like: 1. LimitReportsByBranch 2. reports_branches 3. branchcode 4. mybranch 5. function parameters/relationship keys that already use branch
`branch` seems to be used a lot in the koha repo for things like `branchcode`, `mybranch`, `branchname`, etc. Keeping my variable and functions as `branch` seems like it would be more consistent with the rest of the repo, but if we're trying to shift away from this, I can work `library` in place of `branch`.
You're absolutely right that there's a lot of usage of "branch" in the code and database. You don't need to worry about changing any of that and can absolutely use "branch" as a variable and table/field name. You're correct in the 3 UI things you listed in the first group. In the second group, I'd maybe change the system preference name but the other 4 things are fine as they are. -- You are receiving this mail because: You are watching all bug changes.