https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28656 --- Comment #15 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- (In reply to Marcel de Rooy from comment #11)
+ type => { '!=' => [ 'Writeoff', 'REFUND', 'DISCOUNT' ] }
+ $self->credits( { credit_type_code => [ 'WRITEOFF', 'DISCOUNT', 'REFUND' ] } )->total;
Any reason for case differences here?
Legacy: Offsets had 'Writeoff' but accountlines had 'WRITEOFF'.. we switch from using the offset type to using the accountline type in this line (as is expected with bug 22435)
If these three types make a special group, should we move that to a routine instead of hardcoding them here and there?
Indeed, I started working on that as can be seen in the filter_by's added to Koha::Account::Offsets.. I can now start using those and add proper tests. -- You are receiving this mail because: You are watching all bug changes.