https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24488 --- Comment #133 from Joonas Kylmälä <joonas.kylmala@helsinki.fi> --- (In reply to Jonathan Druart from comment #132)
I had a (quick) look at how we could move the @all_items construction into a Koha::Items->filter_by_ method. I didn't find a simply way to do it, keeping code readable and without duplication.
Having it under Koha::Items was not my intention and would not lead to any clearer result. It should be something like Koha::Holds->find($biblionumber)->items_that_can_fill and Koha::Hold->items_that_can_fill. But for this we need the CanItemFillHold from https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26659#c6 I think. And of course some other naming scheme might be better, take items_that_can_fill as just an example. -- You are receiving this mail because: You are watching all bug changes.