https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38195 --- Comment #1 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 187161 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=187161&action=edit Bug 38195: Add Koha::EDI::Account and Koha::EDI::Accounts object classes This patch introduces Koha::Object-based classes for managing vendor EDI accounts, replacing direct DBIx::Class result access with proper Koha object wrappers. New classes: - Koha::EDI::Account: Object class representing a single EDI account - Koha::EDI::Accounts: Objects class for collections of EDI accounts The Koha::EDI::Account class provides accessor methods for all related objects following modern Koha naming conventions: - vendor() - Returns the associated Koha::Acquisition::Bookseller - file_transport() - Returns the associated Koha::File::Transport - shipment_fund() - Returns the Koha::Acquisition::Fund for shipment fund - files() - Returns Koha::Edifact::Files (EDIFACT interchange files) The Schema Result class has been updated with koha_object_class() and koha_objects_class() helper methods to enable automatic object inflation. This modernization enables cleaner code in controllers and provides a consistent API for working with EDI accounts throughout the codebase. -- You are receiving this mail because: You are watching all bug changes.