https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27946 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |BLOCKED --- Comment #51 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- + $debit_line = $self->account->add_debit( + { + amount => $amount, + user_id => C4::Context->userenv ? C4::Context->userenv->{'number'} : undef, I would expect $self->borrowernumber here instead of going to context? Note btw that this field (in debit lines) user_id is chosen VERY unfortunate. We already had the mixup on the other report. It should be renamed (but not here). -- You are receiving this mail because: You are watching all bug changes.