https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41562 --- Comment #7 from Jonathan Druart <jonathan.druart@gmail.com> --- (In reply to David Cook from comment #5)
(In reply to Jonathan Druart from comment #4)
(In reply to David Cook from comment #3)
I like the idea, but should we be namespacing these more?
Can you detail what you suggest exactly please?
Oh yeah my bad. I just mean putting it under something like window.Koha.permissions and window.Koha.prefs.
Of course, as I say that, I know we haven't been great about the use of window.Koha and window.KOHA in the past.
In the Koha code, I see Koha.i18n, Koha.frameworkPlugins, KOHA.coce, KOHA.browser, KOHA.LocalCover, KOHA.Preferences, KOHA.AJAX... I imagine some are used globally while others are only used locally on a single page...
Maybe something like window.Koha.global.permissions / window.Koha.global.prefs.
I'm not sure. It's just got a thought to avoid collisions with other Javascript and to make it clear that it's Koha code specifically.
Yes, I think it makes sense. However I am suggesting to have a follow-up bug report for that, Owen already tested and signed off on a lot of bugs, and it will be messy to fix same one by one. -- You are receiving this mail because: You are watching all bug changes.