https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38408 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au --- Comment #4 from David Cook <dcook@prosentient.com.au> --- This makes a lot of sense conceptually. I can't believe we didn't do this years ago. I've got a few questions and comments though: 1. Is there are a reason you moved around a bunch of the top "use" statements? It makes it harder to see what's actually changed at the top. 2. There's a 'my $chunk_size = 100000;' at the top of the script which appears to be unused? 3. It wouldn't hurt to add some more code comments to make it easier to read/understand what's happening. Not sure that I follow the math when just reading the code. I would've expected chunk_size to stay fixed and $num_records_exported to be the number of records actually exported. Not sure this all adds up... but don't have time to test right now. -- You are receiving this mail because: You are watching all bug changes.