https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34008 --- Comment #16 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Andreas Jonsson from comment #14)
* I have removed the explicit embed.
Good!
* I've attached a patch for renaming to item_type
Good!
* As for renaming other attributes I am open to suggestions. My personal preference is to stay consistent with the database column names, however.
https://wiki.koha-community.org/wiki/Coding_Guidelines_-_API#SWAGGER1.2:_Res... and we have used RFCs to propose attribute namings in the past: https://wiki.koha-community.org/wiki/REST_api_RFCs I wouldn't suggest you add an RFC, but pick ideas from there. -- You are receiving this mail because: You are watching all bug changes.