https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 --- Comment #188 from Joonas Kylmälä <joonas.kylmala@helsinki.fi> --- Comment on attachment 78690 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=78690 Bug 19893 - Alternative optimized indexing for Elasticsearch Review of attachment 78690: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=19893&attachment=78690) ----------------------------------------------------------------- ::: Koha/SearchEngine/Elasticsearch.pm @@ +333,5 @@
+ } + push @{$record_document->{$target}}, $_data; + } + } + foreach my $record (@{$records}) {
Instead of stacking multiple for loops here, we can move this block to its own function, maybe called marc_record_to_document. This should make it easier to understand the code as the for loop would be then named and code doesn't go horizontally off the screen, right? -- You are receiving this mail because: You are watching all bug changes.