http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7839 --- Comment #12 from David Cook <dcook@prosentient.com.au> --- (In reply to comment #10)
QA comments: 1 the sub "get" in "getAttachedSubscriptions" is improperly spelled. It should be GetAttachedSubscriptions 2 the sub name is wrong I think: - Get...Subscriptions let think it returns a list of subscriptions, that's the case, that's OK - the "Attached" keyword is related to nothing. And there is no reference to the borrowernumber or routinglist thing. This sub should have another name. Something like GetSubscriptionsFromRoutinglistSubscriber or GetSubscriptionsFromBorrower 3 the + JOIN subscriptionroutinglist ON subscriptionroutinglist.subscriptionid = subscription.subscriptionid could be written + JOIN subscriptionroutinglist ON USING(subscriptionid) (not requested for passed QA status, but shorter and should be used as much as possible in the code) 4 the new script and C4/Serials.pm passes perlcritic 5 prove xt/author/translatable-templates.t xt/author/valid-templates.t is OK as well
Please provide a follow-up or an updated fix for point 1, 2 and optionnally 3 to earn passed QA status (and be the 183th committer to join the list of Koha committers ;-) )
Sounds good, Paul. It's been a busy few days, but I'll be sure to get on that when I find the time! As for the list of Koha committers, I think that you already put me on there as the 178th ;). -- You are receiving this mail because: You are watching all bug changes.