https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41728 --- Comment #7 from Tomás Cohen Arazi (tcohen) <tomascohen@gmail.com> --- (In reply to Tomás Cohen Arazi (tcohen) from comment #6)
(In reply to Jonathan Druart from comment #5)
Wondering if this is not a good candidate for the Koha::Policy namespace.
The main reason I didn't use the Policy namespace is the return value i.e. boolean (policy current) vs the aggregate class with many return values.
This was just to illustrate, it also returns: * cardnumber min/max length * a branchcode
We could move into something like:
```perl Koha::Availability::Result # Base result class Koha::Policy::Checkin::Availability # Policy namespace, availability focus Koha::Policy::Checkout::Availability
```
^^^ that's my proposal if people wants to move it to the `Koha::Policy` namespace, making the 'Availability' classes consistently return a `Koha::Availability::Result` object. I even envision the object could also carry the JWT for the 'Confirmation Flow' and maybe ways to validate the JWT (e.g. Koha::Availability::Result->new_from_jwt that would explode if JTW validation fails, etc) -- You are receiving this mail because: You are watching all bug changes.