https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27944 --- Comment #10 from Agustín Moyano <agustinmoyano@theke.io> --- Hi Marcel (In reply to Marcel de Rooy from comment #7)
Agustin: I still have some doubts about the atomicupdate.
You do an UPDATE for notice AR_PENDING and an insert for the new AR_REQUESTED. Generally we should be very careful with UPDATES on existing notices. This one is too generic and will unnecessarily? remove customized texts. The insert could be an INSERT IGNORE btw.
Thanks, missed that
I would suggest to use a new name for the former AR_PENDING notice and only rename it in the atomicupdate. Like AR_RECEIVED. Do not touch the text. And after that add a 'new' notice AR_PENDING (..) with the new text.
In the second patch you add AR_REQUESTED but note that you insert the text for the PENDING state ! So you mix them up here. Obviously, the changes for patch1 should reflect in patch2.
That was intentional, AR_REQUESTED should have the same text as AR_PENDING now has.. it tells the patron that the request was received. I did not realize those messages were customizable, so, what I'll do is in atomicupdate I'll first update message code from AR_PENDING to AR_REQUESTED (keeping that way customized messages) and then I'll insert (ignore) the new AR_PENDING message. Sounds good? Cheers. -- You are receiving this mail because: You are watching all bug changes.