http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9755 --- Comment #21 from Jared Camins-Esakov <jcamins@cpbibliography.com> --- (In reply to comment #18)
Couple comments:
- Please rename the 'Koha::Record' class; as it is, the name is too generic. After all, Koha has lots of record types, many of which are not MARC. I suggest either 'Koha::MARC::Record' (following MARC::Record) or perhaps 'Koha::Metadata::MARC' (allowing for Koha::Metadata::MODS, etc.) or 'Koha::Util::MARC'.
I've decided I'm attached to Koha::Record, because my reasoning behind using it was that it would be nice to be able to merge non-MARC records, so I've gone a bit further in a follow-up and made the class schema-sensitive, moving the MARC-specific code to Koha::Util::MARC.
- I think references to the 999 and 955 tags would be better handled by looking up the tag that the MARC framework uses to store biblio.biblionumber rather than using magic numbers.
Fixed.
Setting back to in discussion, as I do not intend to push this until (at least) the class has a better name.
-- You are receiving this mail because: You are watching all bug changes.