https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41410 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #9 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- This worked as described and all tests pass! It should not be connected to LocalHoldsPriority. These two features are adjacent but distinct and each should be usable without the other. LocalHoldsPriority alters which patron's hold will be filled first while LocalExclusivity alters which items can be used to fill a hold. Desired changes: - Rename LocalHoldsPriorityExclusivityPeriod to LocalHoldsExclusivityPeriod - Flag hold fill targets as local_holdgroup_match regardless of LocalHoldsPriority value I believe that will require sysprefs for LocalHoldsExclusivityPatronControl and LocalHoldsExclusivityItemControl in order to determine how to check for matches. I think it's ok for exclusivity to always be enforced by library hold group, if one is defined (unlike LocalHoldsPriority, which can be set to work only by library, ignoring groups). -- You are receiving this mail because: You are watching all bug changes.