https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23586 --- Comment #7 from Andreas Jonsson <andreas.jonsson@kreablo.se> --- Since the problem is likely caused by the confusion caused by the fact that the variable name $branch is sometimes used for branchnumbers and sometimes for library objects I think that it is a good idea to change the variable names. Also, I think it would be a good idea to add to the coding standards how to name variables containing objects and object identities. These types of errors should really be caught by a type system at compile time. But in the absense of a type system, we can at least improve the situation by having a consistent variable naming scheme. The QA-team could also consider performing tests with the mysql query log enabled and querying for patterns like '=HASH(' which could catch some problems. -- You are receiving this mail because: You are watching all bug changes.