17 Sep
2024
17 Sep
'24
9:31 a.m.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37895 --- Comment #8 from Julian Maurice <julian.maurice@biblibre.com> --- I generally write the "happy path" in the try block, like this: try { $dbh->do(q{}); say_success( $out, "Database modification was successful!" ); } catch { say_failure( $out, "Database modification failed with errors: $_" ); } I think it's more readable than the SQL14 example: less code, less indentation, and you can read the whole "happy path" in one go. But maybe there's a catch (ah!) somewhere with this approach ? -- You are receiving this mail because: You are watching all bug changes.