https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28413 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au --- Comment #2 from David Cook <dcook@prosentient.com.au> --- I think that this is an improvement, but it would be nice to not have the job type hard-coded into the process method. Personally, I'd like the job type to either be the fully qualified module name (e.g. Koha::BackgroundJob::BatchUpdateBiblio) or a shortened version (e.g. BatchUpdateBiblio), so that Koha::BackgroundJob::process() could to "load $job_type;" (using Module::Load) and "$job_type->process($args)". But perhaps that's out of scope for this change.. -- You are receiving this mail because: You are watching all bug changes.