[Bug 22144] New: Add method marc() to Koha::Biblio
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Bug ID: 22144 Summary: Add method marc() to Koha::Biblio Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org Target Milestone: --- It would be very convenient to be able to retrieve a bib's MARC::Record object directly from biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary MARC fields that aren't stored in the database. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 84076 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84076&action=edit Bug 22144: Add method marc() to Koha::Biblio It would be very convenient to be able to retrieve a bib's MARC::Record object directly from biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary MARC fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |kyle@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |josef.moravec@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 terahuitunua@catalyst.net.nz changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84076|0 |1 is obsolete| | --- Comment #2 from terahuitunua@catalyst.net.nz --- Created attachment 84093 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84093&action=edit Bug 22144: Add method marc() to Koha::Biblio It would be very convenient to be able to retrieve a bib's MARC::Record object directly from biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary MARC fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t Signed-off-by: Te Rahui Tunua <terahuitunua@catalyst.net.nz> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 terahuitunua@catalyst.net.nz changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |terahuitunua@catalyst.net.n | |z Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84093|0 |1 is obsolete| | --- Comment #3 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 84137 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84137&action=edit Bug 22144: Add method marc() to Koha::Biblio It would be very convenient to be able to retrieve a bib's MARC::Record object directly from biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary MARC fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t Signed-off-by: Te Rahui Tunua <terahuitunua@catalyst.net.nz> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |In Discussion CC| |tomascohen@gmail.com --- Comment #4 from Tomás Cohen Arazi <tomascohen@gmail.com> --- While we really need to move things into Koha::Biblio, we might better keep in mind that we now have biblio_metadata, which isn't actually tied to a specific serialization format and data schema. I'm not implying we should move C4 code into Koha::Biblio to have something like this (we should, in a mid term) but at least we should leave room for a more general approach: at least return a metadata object, in the lines of Koha::MetadataRecord which "can" be a MARC record. My two cents. I will think about it, because this would benefit the API develpment too. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=22155 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |22155 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22155 [Bug 22155] biblio_metadata.marcflavour should be renamed 'schema' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 --- Comment #5 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 84205 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84205&action=edit Bug 22144 [QA Followup]: Move Koha::Biblio::marc to Koha::Biblio::Metadata::record -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|22155 | Status|Signed Off |In Discussion Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22155 [Bug 22155] biblio_metadata.marcflavour should be renamed 'schema' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Add method marc() to |Add method metadata() to |Koha::Biblio |Koha::Biblio -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |22155 See Also|https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=22155 | Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22155 [Bug 22155] biblio_metadata.marcflavour should be renamed 'schema' -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |22194 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22194 [Bug 22194] Add Koha::Exceptions::Metadata -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84137|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84205|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 --- Comment #6 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 84343 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84343&action=edit Bug 22144: Add method metadata() to Koha::Biblio It would be very convenient to be able to retrieve a bib's attached metadata objects directly from the biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary metadata fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t Signed-off-by: Te Rahui Tunua <terahuitunua@catalyst.net.nz> Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 --- Comment #7 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Created attachment 84344 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84344&action=edit Bug 22144: (QA follow-up) Prepare the ground for other formats This patch refactors the original implementation so it is ready for supporting other formats. It also adds some error handling. To test: - Apply this patch - Run: $ kshell k$ prove t/db_dependent/Koha/Biblio/Metadata.t => SUCCESS: Tests pass! - Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version|unspecified |master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84343|0 |1 is obsolete| | Attachment #84344|0 |1 is obsolete| | --- Comment #8 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 84345 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84345&action=edit Bug 22144: Add method metadata() to Koha::Biblio It would be very convenient to be able to retrieve a bib's attached metadata objects directly from the biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary metadata fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t Signed-off-by: Te Rahui Tunua <terahuitunua@catalyst.net.nz> Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 --- Comment #9 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 84346 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84346&action=edit Bug 22144: (QA follow-up) Prepare the ground for other formats This patch refactors the original implementation so it is ready for supporting other formats. It also adds some error handling. To test: - Apply this patch - Run: $ kshell k$ prove t/db_dependent/Koha/Biblio/Metadata.t => SUCCESS: Tests pass! - Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84345|0 |1 is obsolete| | --- Comment #10 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 84350 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84350&action=edit Bug 22144: Add method metadata() to Koha::Biblio It would be very convenient to be able to retrieve a bib's attached metadata objects directly from the biblio object. This would be very useful for Template Toolkit syntax in slips and notices where a library would like to use arbitrary metadata fields that aren't stored in the database. Test Plan: 1) Apply this patch 2) prove t/db_dependent/Koha/Biblio.t Signed-off-by: Te Rahui Tunua <terahuitunua@catalyst.net.nz> Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #84346|0 |1 is obsolete| | --- Comment #11 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 84351 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=84351&action=edit Bug 22144: (QA follow-up) Prepare the ground for other formats This patch refactors the original implementation so it is ready for supporting other formats. It also adds some error handling. To test: - Apply this patch - Run: $ kshell k$ prove t/db_dependent/Koha/Biblio/Metadata.t => SUCCESS: Tests pass! - Sign off :-D Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |josef.moravec@gmail.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |nick@bywatersolutions.com Status|Passed QA |Pushed to Master --- Comment #12 from Nick Clemens <nick@bywatersolutions.com> --- Awesome work all! Pushed to master for 19.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Bug 22144 depends on bug 22155, which changed state. Bug 22155 Summary: biblio_metadata.marcflavour should be renamed 'schema' https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22155 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Bug 22144 depends on bug 22194, which changed state. Bug 22194 Summary: Add Koha::Exceptions::Metadata https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22194 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED --- Comment #13 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Enhancement, will not be backported to 18.11.x series. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22144 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |23425 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23425 [Bug 23425] Search explodes with "invalid data, cannot decode object" -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org