[Bug 15878] New: C4::Barcodes::hbyymmincr should have/require a default branch or provide an error
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Bug ID: 15878 Summary: C4::Barcodes::hbyymmincr should have/require a default branch or provide an error Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: gmcharlt@gmail.com Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org When creating a new hbyymmincr barcode no branch is used if none is passed in. If the format requires hb=homebranch it shouldn't be able to be created without one. To recreate: 1 - prove -v t/db_dependent/Barcodes.t 2 - observe that in output above no hb component is found in the generated barcodes This works in cataloguing/value_builder/barcode.pl because a branchcode is passed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #1 from Nick Clemens <nick@bywatersolutions.com> --- db_max for this format also has a similar problem to 'annual' in bug 15877 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #2 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51477 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51477&action=edit Bug 15878 - Updated unit tests for hbyymmincr barcodes Test plan in second patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51477|0 |1 is obsolete| | --- Comment #3 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51478 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51478&action=edit Bug 15878 - Updated unit tests for hbyymmincr barcodes Test plan in second patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #4 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51479 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51479&action=edit Bug 15878 - C4::Barcodes::hbyymmincr inccorectly calculates max and should warn when no branchcode present Test plan: 1 - prove t/db_dependent/Barcodes.t 2 - All should pass 3 - Apply first patch (unit tests update) 4 - Tests should fail on values and warnings 5 - Apply second patch 6 - All tests should now pass -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|C4::Barcodes::hbyymmincr |C4::Barcodes::hbyymmincr |should have/require a |inccorectly calculates max |default branch or provide |and should warn when no |an error |branchcode present -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |normal Blocks| |14752 Assignee|gmcharlt@gmail.com |nick@bywatersolutions.com Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14752 [Bug 14752] Add multiple copies to a basket at once -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51478|0 |1 is obsolete| | --- Comment #5 from Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> --- Created attachment 51624 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51624&action=edit [SIGNED-OFF] Bug 15878 - Updated unit tests for hbyymmincr barcodes Test plan in second patch Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51479|0 |1 is obsolete| | --- Comment #6 from Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> --- Created attachment 51625 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51625&action=edit [SIGNED-OFF] Bug 15878 - C4::Barcodes::hbyymmincr inccorectly calculates max and should warn when no branchcode present Test plan: 1 - prove t/db_dependent/Barcodes.t 2 - All should pass 3 - Apply first patch (unit tests update) 4 - Tests should fail on values and warnings 5 - Apply second patch 6 - All tests should now pass Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Work as described Removed tab on line 47 of C4/Barcodes/hbyymmincr.pm No more qa errors -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |bgkriegel@gmail.com Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #7 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Comment on attachment 51624 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51624 [SIGNED-OFF] Bug 15878 - Updated unit tests for hbyymmincr barcodes Review of attachment 51624: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=15878&attachment=51624) ----------------------------------------------------------------- ::: t/db_dependent/Barcodes.t @@ +84,4 @@
};
+$schema->storage->txn_begin;
There is an issue (existed before this patch), the transaction should begin in the subtests. @@ +96,5 @@
+ source => 'Branch', + branchcode => 'LETTERS', + }); + + my $branchcode_1 = "LETT";
LETT vs LETTERS? $barcode_branch is never used later. @@ +97,5 @@
+ branchcode => 'LETTERS', + }); + + my $branchcode_1 = "LETT"; + print "$branchcode_1\n";
Unused debug statement. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |jonathan.druart@bugs.koha-c | |ommunity.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #8 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51688 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51688&action=edit Bug 15878 - QA Followup * Remove debug statment * Move transcation start * Remove unused testbuilder object -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |16561 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16561 [Bug 16561] Regression caused by 15877 - t/db_dependent/Barcodes.t deletes all items from a DB -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51624|0 |1 is obsolete| | --- Comment #9 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51690 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51690&action=edit Bug 15878 - Updated unit tests for hbyymmincr barcodes Test plan in second patch Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51625|0 |1 is obsolete| | --- Comment #10 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51691 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51691&action=edit Bug 15878 - C4::Barcodes::hbyymmincr inccorectly calculates max and should warn when no branchcode present Test plan: 1 - prove t/db_dependent/Barcodes.t 2 - All should pass 3 - Apply first patch (unit tests update) 4 - Tests should fail on values and warnings 5 - Apply second patch 6 - All tests should now pass Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Work as described Removed tab on line 47 of C4/Barcodes/hbyymmincr.pm No more qa errors -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51688|0 |1 is obsolete| | --- Comment #11 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 51692 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51692&action=edit Bug 15878 - QA Followup * Remove debug statment * Move transcation start * Remove unused testbuilder object Rebased on top of 16561 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #51690|0 |1 is obsolete| | Attachment #51691|0 |1 is obsolete| | Attachment #51692|0 |1 is obsolete| | --- Comment #12 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 51694 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51694&action=edit Bug 15878 - Updated unit tests for hbyymmincr barcodes Test plan in second patch Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> Bug 15878 - QA Followup * Remove debug statment * Move transcation start * Remove unused testbuilder object Rebased on top of 16561 Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 51695 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=51695&action=edit Bug 15878 - C4::Barcodes::hbyymmincr inccorectly calculates max and should warn when no branchcode present Test plan: 1 - prove t/db_dependent/Barcodes.t 2 - All should pass 3 - Apply first patch (unit tests update) 4 - Tests should fail on values and warnings 5 - Apply second patch 6 - All tests should now pass Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Work as described Removed tab on line 47 of C4/Barcodes/hbyymmincr.pm No more qa errors Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 --- Comment #14 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- I have squashed 1st & 3rd for the readability. Thanks for the quick patch Nick! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kyle@bywatersolutions.com Status|Passed QA |Pushed to Master --- Comment #15 from Kyle M Hall <kyle@bywatersolutions.com> --- Pushed to master for 16.05, thanks Nick! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15878 Julian Maurice <julian.maurice@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable CC| |julian.maurice@biblibre.com --- Comment #16 from Julian Maurice <julian.maurice@biblibre.com> --- Patches pushed to 3.22.x, will be in 3.22.7 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org