[Bug 27503] New: Rename system preference virtualshelves to AllowLists
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Bug ID: 27503 Summary: Rename system preference virtualshelves to AllowLists Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: aleisha@catalyst.net.nz QA Contact: testopia@bugs.koha-community.org find all of the places in the code that refer to the 'virtualshelves' system preference and rename them to 'AllowLists' write an atomic update to rename the virtualshelves system preference to AllowLists in the preferences table in the database rename the virtualshelves syspref in sysprefs.sql refer to bug 10328 for an example -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Aleisha Amohia <aleisha@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |Academy Blocks| |10327 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10327 [Bug 10327] Rename poorly named system preferences -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 James O'Keeffe <jamespfk@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED CC| |jamespfk@gmail.com Assignee|koha-bugs@lists.koha-commun |jamespfk@gmail.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 --- Comment #1 from James O'Keeffe <jamespfk@gmail.com> --- Created attachment 115487 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115487&action=edit Bug 27503 Work In Progress: Rename system preference virtualshelves to AllowLists -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 James O'Keeffe <jamespfk@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 --- Comment #2 from James O'Keeffe <jamespfk@gmail.com> --- Created attachment 115496 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115496&action=edit Bug 27503: Rename system preference virtualshelves to AllowLists This patch renames virtualshelves to AllowLists Test plan: 1. In Koha Administration, search System preferences for virtualshelves 2. Note the virtualshelves preference 3. Apply the patch and run updatedatabase.pl 4. Search system preferances for virtualshelves, there should be no results 5. Search system preferances for AllowLists 6. ensure that the preferance runs correctly, as if it were virtualshelves. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 James O'Keeffe <jamespfk@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #115487|0 |1 is obsolete| | Attachment #115496|0 |1 is obsolete| | --- Comment #3 from James O'Keeffe <jamespfk@gmail.com> --- Created attachment 115499 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115499&action=edit Bug 27503: Rename system preference virtualshelves to AllowLists This patch renames virtualshelves to AllowLists Test plan: 1. In Koha Administration, search System preferences for virtualshelves 2. Note the virtualshelves preference 3. Apply the patch and run updatedatabase.pl 4. Search system preferances for virtualshelves, there should be no results 5. Search system preferances for AllowLists 6. ensure that the preferance runs correctly, as if it were virtualshelves. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- We've had a bit of a discussion about that on on IRC earlier our day. Allowlists is a little confusing as the term is also used as a replacement for "whitelist". As this only appears to affect the OPAC list feature, i'd suggest OpacLists (similar to the cart one. What do you think? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 --- Comment #5 from Aleisha Amohia <aleisha@catalyst.net.nz> --- I think in that case, OPACLists is a good alternative. We would also want to move the syspref to opac.pref and change the description to be clearer. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 James O'Keeffe <jamespfk@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 James O'Keeffe <jamespfk@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #115499|0 |1 is obsolete| | --- Comment #6 from James O'Keeffe <jamespfk@gmail.com> --- Created attachment 115647 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115647&action=edit Bug 27503: Rename system preference virtualshelves to AllowLists This patch renames virtualshelves to OpacLists Test plan: 1. In Koha Administration, search System preferences for virtualshelves 2. Note the virtualshelves preference 3. Apply the patch and run updatedatabase.pl 4. Search system preferances for virtualshelves, there should be no results 5. Search system preferances for OpacLists 6. ensure that the preferance runs correctly, as if it were virtualshelves. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Rename system preference |Rename system preference |virtualshelves to |virtualshelves to OpacLists |AllowLists | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #7 from David Nind <david@davidnind.com> --- Hi James/Aleisha/Katrin. I like OpacLists much better than virtualshelves (or AllowLists), so a nice improvement! A couple of things I noticed in testing: 1. Should it be OpacLists or OPACLists - the naming of system preferences with either OPAC or Opac in the name is a bit of a mixed bag! I think I would prefer OPAC, so it would then be OPACLists. 2. Database update - is there supposed to be a database update for this change? There is nothing in the patch, so running updatedatabase doesn't do anything. 3. Text for system preference description - Opac should be spelt as OPAC to be consistent with other descriptions for system preferences. Also "saved lists of books" - as the lists could include catalog records for many types of things, maybe a more generic wording could be used, such as records or items. My suggestion would by: "Allow staff and patrons to create and view saved lists of items in the OPAC: " David -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #115499|1 |0 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hi David,
1. Should it be OpacLists or OPACLists - the naming of system preferences with either OPAC or Opac in the name is a bit of a mixed bag! I think I would prefer OPAC, so it would then be OPACLists.
I don't have a preference there, but OPACLists makes sense.
2. Database update - is there supposed to be a database update for this change? There is nothing in the patch, so running updatedatabase doesn't do anything.
We definitely need a database update. It looks like something went wrong here, as the initial patch made many more changes to files and included a database update. But doesn't have the new name now :( I believe git bz is to blame. The follow-up had the exact same subject, so one got overwritten with the other. It also needs to be fixed to reflect the new name we picked.
3. Text for system preference description - Opac should be spelt as OPAC to be consistent with other descriptions for system preferences. Also "saved lists of books" - as the lists could include catalog records for many types of things, maybe a more generic wording could be used, such as records or items. My suggestion would by:
"Allow staff and patrons to create and view saved lists of items in the OPAC: "
Actually, I would much prefer records, as lists can only be used on record level and this would lead to a lot of wrong translations (I know in English lists have items, but not the same word in other languages :) ) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #115647|Bug 27503: Rename system |Bug 27503: (follow up) description|preference virtualshelves |Rename AllowLists to |to AllowLists |OpacLists --- Comment #9 from David Nind <david@davidnind.com> --- Comment on attachment 115647 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115647 Bug 27503: (follow up) Rename AllowLists to OpacLists Not sure whether this is the best way - renaming title for the follow up patch so it is different from the initial patch name. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #115647|Bug-27503-Rename-system-pre |Bug-27503-follow-up-rename- filename|ference-virtualshelves-.pat |allowlists-to-opaclists.pat |ch |ch --- Comment #10 from David Nind <david@davidnind.com> --- Comment on attachment 115647 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115647 Bug 27503: (follow up) Rename AllowLists to OpacLists Rename file name for follow up patch. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Patch doesn't apply --- Comment #11 from David Nind <david@davidnind.com> --- Patch no longer applies, I will have a go at rescuing it (not sure how to do exactly, but will try and work it out). -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=34235 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=36910 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 Rebecca Coert <rcoert@arlingtonva.us> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |rcoert@arlingtonva.us -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=19501 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27503 --- Comment #12 from David Nind <david@davidnind.com> --- Looks like I didn't have a go at rescuing it! With the discussion on other bugs, such as bug 34235 and bug 36910, I think renaming it to 'Lists' would be more appropriate. Then it would make sense to set the options in one system preference, such as whether to enable their use on the OPAC, staff interface, or both. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org