[Bug 14589] New: Replace fetch CGI::Cookie calls
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Bug ID: 14589 Summary: Replace fetch CGI::Cookie calls Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: gmcharlt@gmail.com Reporter: m.de.rooy@rijksmuseum.nl QA Contact: testopia@bugs.koha-community.org -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 --- Comment #1 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41125 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41125&action=edit Bug 14589: Replace fetch CGI::Cookie calls This patch is inspired by the change in bug 14588. It replaces the indirect object syntax for CGI::Cookie. Some trivial corrections are made to authorities/merge_ajax.pl just as bug 14588 does for cataloguing. Test plan: Run the URL authorities/merge_ajax.pl in staff. Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|gmcharlt@gmail.com |m.de.rooy@rijksmuseum.nl Status|NEW |Needs Signoff Severity|enhancement |minor Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=14588 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #41125|0 |1 is obsolete| | --- Comment #2 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41457 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41457&action=edit Bug 14589: Replace fetch CGI::Cookie calls This patch is inspired by the change in bug 14588. It replaces the indirect object syntax for CGI::Cookie. Some trivial corrections are made to authorities/merge_ajax.pl just as bug 14588 does for cataloguing. Test plan: Run the URL authorities/merge_ajax.pl in staff. Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |14321 Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14321 [Bug 14321] Merge UploadedFile and UploadedFiles into Koha::Upload -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 --- Comment #3 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Rebased on top of 6874. I need this (trivial) patch for 14321. Please add your (easy) signoff.. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #41457|0 |1 is obsolete| | --- Comment #4 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41675 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41675&action=edit Bug 14589: Replace fetch CGI::Cookie calls This patch is inspired by the change in bug 14588. It replaces the indirect object syntax for CGI::Cookie. Some trivial corrections are made to authorities/merge_ajax.pl just as bug 14588 does for cataloguing. Test plan: Run the URL authorities/merge_ajax.pl in staff. Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=11299 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 --- Comment #5 from M. Tompsett <mtompset@hotmail.com> --- Comment on attachment 41675 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41675 Bug 14589: Replace fetch CGI::Cookie calls Review of attachment 41675: --> (http://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=14589&attachment=41675) ----------------------------------------------------------------- There is scope creep as noted below. It would make more sense to have a "Replace 'new CGI' calls" bug separately, as this occurs in more than just these places. ::: tools/background-job-progress.pl @@ +30,4 @@
use CGI::Cookie; # need to check cookies before # having CGI parse the POST request
+my $input = CGI->new;
Scope creep. @@ +51,4 @@
$job_status = $job->status(); }
+my $reply = CGI->new;
Scope creep. ::: tools/upload-file-progress.pl @@ +47,4 @@
} }
+my $reply = CGI->new;
Scope creep. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Replace fetch CGI::Cookie |Adjust |calls |authorities_merge_ajax and | |replace some indirect | |syntax --- Comment #6 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to M. Tompsett from comment #5)
There is scope creep as noted below. It would make more sense to have a "Replace 'new CGI' calls" bug separately, as this occurs in more than just these places.
I would not really mind, but most important for me now is to get bug 14321 rolling. And this is a dependency.. What about a title change :) ? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #41675|0 |1 is obsolete| | --- Comment #7 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41691 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41691&action=edit Bug 14589: Adjust authorities_merge_ajax and replace some indirect syntax This patch does the following: [1] Adjust authorities_merge_ajax just as in bug 14588. [2] Replace some indirect syntax for fetch GGI::Cookie. [3] Along the way replace some new CGI's. Note that I am not aiming to replace them Koha wide. The "fetch class" variant is less readable. Test plan: [1] Run the URL authorities/merge_ajax.pl in staff. [2] Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks|14321 | Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14321 [Bug 14321] Merge UploadedFile and UploadedFiles into Koha::Upload -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 --- Comment #8 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41882 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41882&action=edit Bug 14589: Replace fetch CGI::Cookie calls This patch is inspired by the change in bug 14588. It replaces the indirect object syntax for CGI::Cookie. Some trivial corrections are made to authorities/merge_ajax.pl just as bug 14588 does for cataloguing. NOTE: The changes to tools/upload-file.pl and upload-file-progress.pl are moved to report 14321. Test plan: Run the URL authorities/merge_ajax.pl in staff. Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #41691|0 |1 is obsolete| | Attachment #41882|0 |1 is obsolete| | --- Comment #9 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 41883 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41883&action=edit Bug 14589: Adjust authorities_merge_ajax and replace some indirect syntax This patch does the following: [1] Adjust authorities_merge_ajax just as in bug 14588. [2] Replace some indirect syntax for fetch GGI::Cookie. [3] Along the way replace some new CGI's. Note that I am not aiming to replace them Koha wide. The "fetch class" variant is less readable. NOTE: The changes to tools/upload-file.pl and upload-file-progress.pl are moved to report 14321. Test plan: [1] Run the URL authorities/merge_ajax.pl in staff. [2] Upload a file with Stage MARC records for import. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=14321 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #41883|0 |1 is obsolete| | --- Comment #10 from Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> --- Created attachment 44177 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=44177&action=edit [SIGNED-OFF] Bug 14589: Adjust authorities_merge_ajax and replace some indirect syntax This patch does the following: [1] Adjust authorities_merge_ajax just as in bug 14588. [2] Replace some indirect syntax for fetch GGI::Cookie. [3] Along the way replace some new CGI's. Note that I am not aiming to replace them Koha wide. The "fetch class" variant is less readable. NOTE: The changes to tools/upload-file.pl and upload-file-progress.pl are moved to report 14321. Test plan: [1] Run the URL authorities/merge_ajax.pl in staff. [2] Upload a file with Stage MARC records for import. Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> [1] It runs, but also before patch [2] File uploads without problem No errors -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #44177|0 |1 is obsolete| | --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 44187 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=44187&action=edit Bug 14589: Adjust authorities_merge_ajax and replace some indirect syntax This patch does the following: [1] Adjust authorities_merge_ajax just as in bug 14588. [2] Replace some indirect syntax for fetch GGI::Cookie. [3] Along the way replace some new CGI's. Note that I am not aiming to replace them Koha wide. The "fetch class" variant is less readable. NOTE: The changes to tools/upload-file.pl and upload-file-progress.pl are moved to report 14321. Test plan: [1] Run the URL authorities/merge_ajax.pl in staff. [2] Upload a file with Stage MARC records for import. Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> [1] It runs, but also before patch [2] File uploads without problem No errors Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> We could certainly remove 1 or 2 call to CGI->new in tools/background-job-progress.pl -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14589 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |tomascohen@gmail.com Status|Passed QA |Pushed to Master --- Comment #12 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patch pushed to master. Thanks Marcel! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org