[Bug 43635] New: run_report.pl does not capture or handle errors
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 Bug ID: 43635 Summary: run_report.pl does not capture or handle errors Initiative type: --- Sponsorship --- status: Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Reports Assignee: koha-bugs@lists.koha-community.org Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: lisette@bywatersolutions.com Target Milestone: --- Bug 39164 added a report_sql_max_statement_time_seconds setting to the koha-conf When this limit is reached an error is thrown which is shown in the staff interface: Query execution was interrupted (max_statement_time exceeded) When run_report.pl hits this error the error is warned, but if report is saved it is not saved in saved_reports or emailed if report is being emailed -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 Nick Clemens (kidclamp) <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |39164 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=39164 [Bug 39164] Add max_statement_time to SQL report queries -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |andrew@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 --- Comment #1 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- It'd be helpful if the cron could deliver that error to the intended recipient of the report results -- an email that says "Report X was scheduled to send to you but failed because: ...." -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 Avery Campbell (Butte County Library (CA)) <acampbell@buttecounty.ca.gov> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |acampbell@buttecounty.ca.go | |v --- Comment #2 from Avery Campbell (Butte County Library (CA)) <acampbell@buttecounty.ca.gov> --- To add to Andrew’s comment, maybe also having a notification sent to KohaAdminEmailAddress or create a new SysPref like AddressForFailedOvetdueNotices so that the staff who have access to make changes and/or submit tickets can also know a Cron is failing. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org