https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=43635 Bug ID: 43635 Summary: run_report.pl does not capture or handle errors Initiative type: --- Sponsorship --- status: Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Reports Assignee: koha-bugs@lists.koha-community.org Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: lisette@bywatersolutions.com Target Milestone: --- Bug 39164 added a report_sql_max_statement_time_seconds setting to the koha-conf When this limit is reached an error is thrown which is shown in the staff interface: Query execution was interrupted (max_statement_time exceeded) When run_report.pl hits this error the error is warned, but if report is saved it is not saved in saved_reports or emailed if report is being emailed -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.