[Bug 15799] New: move authorised value related code into Koha::AuthorisedValues - part 2
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Bug ID: 15799 Summary: move authorised value related code into Koha::AuthorisedValues - part 2 Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: ASSIGNED Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: jonathan.druart@bugs.koha-community.org Reporter: jonathan.druart@bugs.koha-community.org QA Contact: testopia@bugs.koha-community.org Blocks: 15779 The first patch (bug 10363) did not take care of the subroutines from C4::Koha. This module contains several subroutines which could be either moved or replaced with a call to Koha::AuthorisedValues: - GetKohaImageurlFromAuthorisedValues - GetAuthValCode - GetAuthValCodeFromField - GetAuthorisedValues - GetAuthorisedValueCategories - GetAuthorisedValueByCode - GetKohaAuthorisedValues - GetKohaAuthorisedValuesFromField - GetKohaAuthorisedValuesMapping - GetKohaAuthorisedValueLib - GetAuthvalueDropbox Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15779 [Bug 15779] Remove unnecessary parts of C4::Koha -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |10363 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10363 [Bug 10363] Move authorised value related code into its own package -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|move authorised value |Move authorised value |related code into |related code into |Koha::AuthorisedValues - |Koha::AuthorisedValues - |part 2 |part 2 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Move authorised value |Move authorised values |related code into |related code into |Koha::AuthorisedValues - |Koha::AuthorisedValues - |part 2 |part 2 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |15800 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15800 [Bug 15800] Koha::AuthorisedValues - Remove C4::Koha::IsAuthorisedValueCategory -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 --- Comment #1 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- IsAuthorisedValueCategory is on bug 15800 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |15797 --- Comment #2 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- GetKohaImageurlFromAuthorisedValues is removed by bug 15797 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15797 [Bug 15797] C4::Koha::GetKohaImageurlFromAuthorisedValues is no longer in use -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |15803 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15803 [Bug 15803] Koha::AuthorisedValues - Remove GetAuthorisedValueCategories -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 --- Comment #3 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 15803 - Koha::AuthorisedValues - Remove GetAuthorisedValueCategories -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 --- Comment #4 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- We have already started to move the authorised values related code to the Koha namespace, but some are still missing. To continue and move C4::Koha::*AuthorisedValues* subroutines to Koha::AuthorisedValues, we will need to join on marc_subfield_structure(.authorised_value which is actually an authorised value category). To do so we need to define a relationship (fk) between the two tables. But we have "special AV" like Asort1 (and friends) , LOST, DAMAGED, etc.) Which could not be in the authorised_values table [yet]. And 3 other "special special AV) like itemtypes, branches and cn_source. Others (undetermined so far) are linked to a marc_subfield_structure from installer/**/marcflavour/**/*framework*.sql, like STACK. My idea would be to move all the AV categories to a new table authorised_value_categories. It will contain only 1 column category_name refered by 1. authorised_values.category, 2. additional_fields.authorised_value_category (others authorised_value field should be renamed like that when they refer AV categories) and 3. iitems_search_fields.authorised_value_category. And, maybe later, auth_subfield_structure, auth_tag_structure, borrower_attribute_types, marc_tag_structure (some are varchar(10) et 20 when they should be 32!) We could imagine more attributes to this table, but don't ask me to add a authorised_value_categories.id as pk please :) We will have to use temporary tables to deal with the DB constraints, to add more fun. Finally the .sql will have to be updated to reflect these changes. I have just started but before to enter in this tunnel I'd like to know if there are a couple of volunteers to test? :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |veron@veron.ch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17216 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17216 [Bug 17216] Add a new table to store authorized value categories -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 --- Comment #5 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Jonathan Druart from comment #4) New table created on bug 17216 - Add a new table to store authorized value categories. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17248 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17248 [Bug 17248] Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 --- Comment #6 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17248 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValueLib -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17249 --- Comment #7 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17249 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValuesFromField Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17249 [Bug 17249] Koha::AuthorisedValues - Remove GetKohaAuthorisedValuesFromField -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17250 --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17250 - Koha::AuthorisedValues - Remove GetAuthValCode Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17250 [Bug 17250] Koha::AuthorisedValues - Remove GetAuthValCode -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17251 --- Comment #9 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17251 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValuesMapping Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17251 [Bug 17251] Koha::AuthorisedValues - Remove GetKohaAuthorisedValuesMapping -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17252 --- Comment #10 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17252 - Koha::AuthorisedValues - Remove GetAuthorisedValueByCode Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17252 [Bug 17252] Koha::AuthorisedValues - Remove GetAuthorisedValueByCode -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17253 --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17253 - Koha::AuthorisedValues - Remove GetKohaAuthorisedValues Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17253 [Bug 17253] Koha::AuthorisedValues - Remove GetKohaAuthorisedValues -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |17642 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17642 [Bug 17642] Authorised values code is broken because of the refactoring -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17844 --- Comment #12 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17844 - Move C4::Koha::get_notforloan_label_of to Koha::AuthorisedValues Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17844 [Bug 17844] Move C4::Koha::get_notforloan_label_of to Koha::AuthorisedValues -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17847 --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Bug 17847 - Move C4::Koha::GetAuthvalueDropbox to Koha::AuthorisedValues Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17847 [Bug 17847] Move C4::Koha::GetAuthvalueDropbox to Koha::AuthorisedValues -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Bug 15799 depends on bug 17844, which changed state. Bug 17844 Summary: Move C4::Koha::get_notforloan_label_of to Koha::AuthorisedValues https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17844 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Bug 15799 depends on bug 17847, which changed state. Bug 17847 Summary: Move C4::Koha::GetAuthvalueDropbox to Koha::AuthorisedValues https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17847 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15799 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |RESOLVED Resolution|--- |FIXED --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- All dependent bugs have been closed - yay! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org