[Bug 29575] New: Add a JS render function equivalent of the patron-title.inc TT include
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Bug ID: 29575 Summary: Add a JS render function equivalent of the patron-title.inc TT include Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff Client Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com Blocks: 28854, 28874, 29275 We need a re-usable function that will use the json patron object as returned from the API and render an equivalent to the TT patron-title.inc output. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28854 [Bug 28854] [ALTERNATIVE] Add ability to create bundles of items https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28874 [Bug 28874] We need javascript equivalents to many of our TT plugins https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29275 [Bug 29275] Use the API to render checkout history for a biblio -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |tomascohen@gmail.com |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Grabbing the code from bug 29275 by Tomas and submitting it here so we can depend on it in other bugs without requiring the whole of 29275 for backports. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 127999 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127999&action=edit Bug 29575: Add $patron_to_html to render patron information in JS This patch adds a re-usable javascript render function that accepts a Koha REST api Patron object and outputs the HTML representation. Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128000 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128000&action=edit Bug 29575: Add JSDoc documentation This patch adds some basic documentation for the $patron_to_html function the patchset introduces. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Grabbing SO from Victor on Bug 29275 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #5 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128004 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128004&action=edit Bug 27975: (follow-up) Patron fields can be empty strings We need to account for empty strings as well as 'null' values in the patron data structure. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #6 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128006 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128006&action=edit Bug 29575: (follow-up) Patron fields can be empty strings We need to account for empty strings as well as 'null' values in the patron data structure. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #128004|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #127999|0 |1 is obsolete| | --- Comment #7 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128038 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128038&action=edit Bug 29575: Add $patron_to_html to render patron information in JS This patch adds a re-usable javascript render function that accepts a Koha REST api Patron object and outputs the HTML representation. Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net> Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #8 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128039 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128039&action=edit Bug 29575: (QA follow-up) Add JSDoc documentation This patch adds some basic documentation for the $patron_to_html function the patchset introduces. Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 128040 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128040&action=edit Bug 29575: (QA follow-up) Patron fields can be empty strings We need to account for empty strings as well as 'null' values in the patron data structure. Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #128000|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #128006|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- I've tested this on a few of the dependant bugs, it's looking great and testing lead me to just these two minor QA follow-ups. Passing QA :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m --- Comment #11 from Fridolin Somers <fridolin.somers@biblibre.com> --- File name is "js-patron-format.inc" but first line comment says "js-patron-title.inc" I suggest we rename file to be closer to existing include "patron-title.inc" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #12 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Fridolin Somers from comment #11)
File name is "js-patron-format.inc" but first line comment says "js-patron-title.inc"
That's a typo.
I suggest we rename file to be closer to existing include "patron-title.inc"
I followed the (already existing) js-format-date.inc file name. I think I prefer it. But can adjust if required, not personally attached. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #13 from Fridolin Somers <fridolin.somers@biblibre.com> --- (In reply to Tomás Cohen Arazi from comment #12)
(In reply to Fridolin Somers from comment #11)
File name is "js-patron-format.inc" but first line comment says "js-patron-title.inc"
That's a typo. Ok then I remove this HTML comments.
I suggest we rename file to be closer to existing include "patron-title.inc"
I followed the (already existing) js-format-date.inc file name. I think I prefer it. But can adjust if required, not personally attached.
OK I like that (its js-date-format.inc) And since method is $patron_to_html it makes sens to name js-patron-format.inc -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #14 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 128639 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128639&action=edit Bug 29575: (RM follow-up) remove HTML comments Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |release-notes-needed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |22.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 --- Comment #15 from Fridolin Somers <fridolin.somers@biblibre.com> --- Pushed to master for 22.05, thanks to everybody involved 🦄 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED CC| |kyle@bywatersolutions.com Status|Pushed to master |RESOLVED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com Text to go in the| |This enhancement adds a release notes| |re-usable javascript render | |function that accepts a | |Koha REST APIi Patron | |object and outputs the HTML | |representation. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |33457 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33457 [Bug 33457] Improve display of fund users when the patron has no firstname -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29575 Lisette Scheer <lisette@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|release-notes-needed | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org