[Bug 34235] New: Make virtualshelves preference more granular
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 Bug ID: 34235 Summary: Make virtualshelves preference more granular Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Lists Assignee: koha-bugs@lists.koha-community.org Reporter: mathsabypro@gmail.com QA Contact: testopia@bugs.koha-community.org CC: m.de.rooy@rijksmuseum.nl Currently the "virtualsheves" preference gives this choice : "Allow staff and patrons to create and view saved lists of books: " 1: "Yes" 0: "No" It should be more granular, and allow the creation of lists by - staff only - patrons only - staff and patron - nobody Also it should be renamed, as the feature in Koha UI is not called "virtual shelves" but "lists". And a list can contain any material, not only "books". -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- The renaming has been filed separately as 27503 already. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=27503 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 --- Comment #2 from mathieu saby <mathsabypro@gmail.com> --- Thanks, I see that. But "OpacList" seems a strange name, as lists can also be used in staff side -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 --- Comment #3 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to mathieu saby from comment #2)
Thanks, I see that. But "OpacList" seems a strange name, as lists can also be used in staff side
When you think about the additional behaviour you mention here, yes. But at the moment it just activates/deactivates in the OPAC. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 Rebecca Coert <rcoert@arlingtonva.us> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |rcoert@arlingtonva.us -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 Lauren Denny <lauren_denny@sil.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |lauren_denny@sil.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=36910 CC| |david@davidnind.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 Michaela Sieber <michaela.sieber@kit.edu> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=19501 CC| |michaela.sieber@kit.edu -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34235 --- Comment #4 from David Nind <david@davidnind.com> --- Reposting my comment from bug 36910 here: With the discussion on other bugs, such as bug 27503 and bug 36910, I think renaming the current system preference to 'Lists' would be more appropriate. Then it would make sense to set the options in one system preference, such as whether to enable their use on the OPAC, staff interface, both, or neither. My proposal is to work on it in two steps: 1. Rename the system preference to 'Lists' (bug 27503) (something I think I can do) 2. Make the options more granular: OPAC, Staff interface, Both, Neither (outside my skill level) I'll attempt to work on bug 27503 to rename the system preference. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org