[Bug 27583] New: Clarify how cash management fits together
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Bug ID: 27583 Summary: Clarify how cash management fits together Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff Client Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com The new(ish) cash management options in Koha aren't clearly defined... you can enable parts of the system without enabling all of it. We should try to clarify the module by more clearly defining how it fits together. I propose to add a 'Cash management' heading under 'Tools' to move the 'Cashuup registers' option to and renaming some of the interface area's to better clarify their purposes. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |13985 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13985 [Bug 13985] Cash Management - Koha as 'Point of Sale' -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |27582 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27582 [Bug 27582] Breadcrumb incorrect for POS: Library details page -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 116156 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=116156&action=edit Bug 27583: Proposed terminology changes This patch impliments some terminology changes and clarifications for the cash management system Test plan 1/ Apply the patches 2/ Enable 'UseCashRegisters' 3/ Navigate around the cash management system (via the Tools menu) 4/ Enable 'EnablePointOfSale' 5/ Navigate around the cash management system (via the Point of sale module) 6/ Comment on what you think about the changes -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de, | |lucy.vaux-harvey@ptfs-europ | |e.com, oleonard@myacpl.org, | |sally.healey@cheshireshared | |services.gov.uk -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #116156|0 |1 is obsolete| | --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 116157 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=116157&action=edit Bug 27583: Proposed terminology changes This patch impliments some terminology changes and clarifications for the cash management system Test plan 1/ Apply the patches 2/ Enable 'UseCashRegisters' 3/ Navigate around the cash management system (via the Tools menu) 4/ Enable 'EnablePointOfSale' 5/ Navigate around the cash management system (via the Point of sale module) 6/ Comment on what you think about the changes -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |andrew@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 ByWater Sandboxes <bws.sandboxes@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #116157|0 |1 is obsolete| | --- Comment #3 from ByWater Sandboxes <bws.sandboxes@gmail.com> --- Created attachment 118127 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=118127&action=edit Bug 27583: Proposed terminology changes This patch impliments some terminology changes and clarifications for the cash management system Test plan 1/ Apply the patches 2/ Enable 'UseCashRegisters' 3/ Navigate around the cash management system (via the Tools menu) 4/ Enable 'EnablePointOfSale' 5/ Navigate around the cash management system (via the Point of sale module) 6/ Comment on what you think about the changes Signed-off-by: Sally <sally.healey@cheshiresharedservices.gov.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Sally <sally.healey@cheshiresharedservices.gov.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #4 from Sally <sally.healey@cheshiresharedservices.gov.uk> --- I like these changes - the placement is logical, and I like the way it displays when you're logged in with a till attached to your session vs without. The POS menu, in particular, is much improved. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |Manual -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #5 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Comment on attachment 118127 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=118127 Bug 27583: Proposed terminology changes Review of attachment 118127: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=27583&attachment=118127) ----------------------------------------------------------------- ::: koha-tmpl/intranet-tmpl/prog/en/modules/pos/register.tt @@ +19,5 @@
+<div id="breadcrumbs"> + <a href="/cgi-bin/koha/mainpage.pl">Home</a> + › <a href="/cgi-bin/koha/tools/tools-home.pl">Cash management</a> + › Transaction history for [% register.name | html %] +</div>
Please don't do this - it breaks the strings up for translations. It's easier to translate the full path for context. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #6 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Katrin Fischer from comment #5)
Comment on attachment 118127 [details] [review] Bug 27583: Proposed terminology changes
Review of attachment 118127 [details] [review]: -----------------------------------------------------------------
::: koha-tmpl/intranet-tmpl/prog/en/modules/pos/register.tt @@ +19,5 @@
+<div id="breadcrumbs"> + <a href="/cgi-bin/koha/mainpage.pl">Home</a> + › <a href="/cgi-bin/koha/tools/tools-home.pl">Cash management</a> + › Transaction history for [% register.name | html %] +</div>
Please don't do this - it breaks the strings up for translations. It's easier to translate the full path for context.
Actually I am having trouble to prove that claim and have quite some errors running gulp po:update hmm. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #7 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- I've proved it for you here.. sorry, I wasn't aware that splitting it nicely over lines caused translations issues.. it's done like that all over the codebase and in my opinion, is much more readable.. such a shame we can't use it :(. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #8 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Having said that, from my layman's perspective having the segments as distinct strings (and being able to share a single translation for the first chunk 'Home' for example seems better for translation rather than worse to me.. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 118224 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=118224&action=edit Bug 27583: (QA follow-up) Undo developer readability I added new lines for each slug of the breadcrumbs (As is the case in many other locations in Koha), but Katrin highlighted that this breaks the string into distinct slugs without context for translation and this is apparently a bad thing. So this patch undoes that change and puts them back onto one long line. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- OK.. I've added a followup to undo the readability improvements. Katrin, can you bring this up as a topic for a dev meeting.. if we really do need to keep breadcrumb slugs all on one line I feel we should have a guideline written for it with clear reasoning so QA team are aware and can enforce the policy. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #118224|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #11 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Obsoleted my final patch.. after some discussion we decided the split wasn't a bad thing. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kyle@bywatersolutions.com Status|Signed Off |Patch doesn't apply -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #118127|0 |1 is obsolete| | --- Comment #12 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 120912 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=120912&action=edit Bug 27583: Proposed terminology changes This patch impliments some terminology changes and clarifications for the cash management system Test plan 1/ Apply the patches 2/ Enable 'UseCashRegisters' 3/ Navigate around the cash management system (via the Tools menu) 4/ Enable 'EnablePointOfSale' 5/ Navigate around the cash management system (via the Point of sale module) 6/ Comment on what you think about the changes Signed-off-by: Sally <sally.healey@cheshiresharedservices.gov.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Patch doesn't apply |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #120912|0 |1 is obsolete| | --- Comment #13 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 122690 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=122690&action=edit Bug 27583: Proposed terminology changes This patch impliments some terminology changes and clarifications for the cash management system Test plan 1/ Apply the patches 2/ Enable 'UseCashRegisters' 3/ Navigate around the cash management system (via the Tools menu) 4/ Enable 'EnablePointOfSale' 5/ Navigate around the cash management system (via the Point of sale module) 6/ Comment on what you think about the changes Signed-off-by: Sally <sally.healey@cheshiresharedservices.gov.uk> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | CC| |m.de.rooy@rijksmuseum.nl -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |This enhancement serves to release notes| |clarify the parts of the | |cash management module by | |updating the names or pages | |and embellishing the | |breadcrumb navigation for | |these pages. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |21.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 --- Comment #14 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Pushed to master for 21.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED Resolution|--- |FIXED --- Comment #15 from Kyle M Hall <kyle@bywatersolutions.com> --- Enhancement not backported. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Bug 27583 depends on bug 27582, which changed state. Bug 27582 Summary: Breadcrumb incorrect for POS: Library details page https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27582 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to stable |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27583 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Component|Staff Client |Fines and fees -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org