[Bug 18941] New: C4:: Budgets GetBudgetByCode should return active budgets over inactive budgets
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Bug ID: 18941 Summary: C4::Budgets GetBudgetByCode should return active budgets over inactive budgets Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Acquisitions Assignee: nick@bywatersolutions.com Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org When closing a budget/creating new budgets at the end of the year fund codes are duplicated. When importing orders from a staged file we retrieve the budget using only the fund code, this is problematic if we have multiple budgets. When we really see the effect is a library that creates a new inactive budget for upcoming year, this budget's fund end up being implicitly selected by DB order. We instead need to explicitly select active funds. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 --- Comment #1 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 65049 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65049&action=edit Bug 18941 - C4::Budgets GetBudgetByCode should return active budgets over inactive budgets To test: 1 - Create an active budget 2 - Create an inactive budget 3 - Ensure they each have a fund with the same code 4 - Set MarcFieldsToOrder to get the budget_code from a marc field 5 - Stage a file using the duplicated code 6 - Add to a basket from the staged file 7 - Add the items 8 - Note funds are encumbered from the inactive budget 9 - Apply patch 10 - Repeat 5-8 with a new basket 11 - Note the active budget is now used -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 --- Comment #2 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 65050 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65050&action=edit Bug 18941 - Unit tests -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtompset@hotmail.com Status|Needs Signoff |Failed QA --- Comment #3 from M. Tompsett <mtompset@hotmail.com> --- I have two problems. 1) this adds a lot of fields because of the JOIN. -- should change the * to aqbudget.* at least 2) if I apply the unit tests but not the fix, I expected a failure. They still passed. How do I know the condition is fixed? Marking Failed QA. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #65049|0 |1 is obsolete| | Attachment #65050|0 |1 is obsolete| | --- Comment #4 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 65125 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65125&action=edit Bug 18941 - Unit tests -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 --- Comment #5 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 65126 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65126&action=edit Bug 18941 - C4::Budgets GetBudgetByCode should return active budgets over inactive budgets To test: 1 - Create an active budget 2 - Create an inactive budget 3 - Ensure they each have a fund with the same code 4 - Set MarcFieldsToOrder to get the budget_code from a marc field 5 - Stage a file using the duplicated code 6 - Add to a basket from the staged file 7 - Add the items 8 - Note funds are encumbered from the inactive budget 9 - Apply patch 10 - Repeat 5-8 with a new basket 11 - Note the active budget is now used -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #65125|0 |1 is obsolete| | --- Comment #6 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 65441 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65441&action=edit [SIGNED-OFF] Bug 18941 - Unit tests Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 --- Comment #7 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 65442 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65442&action=edit [SIGNED-OFF] Bug 18941 - C4::Budgets GetBudgetByCode should return active budgets over inactive budgets To test: 1 - Create an active budget 2 - Create an inactive budget 3 - Ensure they each have a fund with the same code 4 - Set MarcFieldsToOrder to get the budget_code from a marc field 5 - Stage a file using the duplicated code 6 - Add to a basket from the staged file 7 - Add the items 8 - Note funds are encumbered from the inactive budget 9 - Apply patch 10 - Repeat 5-8 with a new basket 11 - Note the active budget is now used Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #65126|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #65441|0 |1 is obsolete| | Attachment #65442|0 |1 is obsolete| | --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 65847 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65847&action=edit Bug 18941 - Unit tests Signed-off-by: Mark Tompsett <mtompset@hotmail.com> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 --- Comment #9 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 65848 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=65848&action=edit Bug 18941 - C4::Budgets GetBudgetByCode should return active budgets over inactive budgets To test: 1 - Create an active budget 2 - Create an inactive budget 3 - Ensure they each have a fund with the same code 4 - Set MarcFieldsToOrder to get the budget_code from a marc field 5 - Stage a file using the duplicated code 6 - Add to a basket from the staged file 7 - Add the items 8 - Note funds are encumbered from the inactive budget 9 - Apply patch 10 - Repeat 5-8 with a new basket 11 - Note the active budget is now used Signed-off-by: Mark Tompsett <mtompset@hotmail.com> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #10 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 17.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m Status|Pushed to Master |Pushed to Stable --- Comment #11 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Pushed to 17.05.x, will be in 17.05.05. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- These patches have been pushed to 16.11.x and will be in 16.11.13. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18941 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtj@kohaaloha.com --- Comment #13 from Mason James <mtj@kohaaloha.com> --- Pushed to 16.05.x, for 16.05.18 release -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org