[Bug 15242] New: Missing subroutine in overdue_notices.pl
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Bug ID: 15242 Summary: Missing subroutine in overdue_notices.pl Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Command-line Utilities Assignee: gmcharlt@gmail.com Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: robin@catalyst.net.nz When parse_letter was renamed to parse_overdue_letter on bug 12933 an error was introduced so that overdue_notices.pl cannot find the subroutine -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #1 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 45105 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=45105&action=edit Bug 15242 - Missing subroutine in overdue_notices.pl This patch changes the call to parse_overdues_letter to use the full namespace to ensure the subroutine can be found. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=12933 Assignee|gmcharlt@gmail.com |nick@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #45105|0 |1 is obsolete| | --- Comment #2 from Marc Véron <veron@veron.ch> --- Created attachment 45115 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=45115&action=edit Bug 15242 - Missing subroutine in overdue_notices.pl This patch changes the call to parse_overdues_letter to use the full namespace to ensure the subroutine can be found. Signed-off-by: Marc Véron <veron@veron.ch> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Marc Véron <veron@veron.ch> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off CC| |veron@veron.ch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |blocker CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- QA Style note, we tend to import routines over adding full namespaces.. I'd prefer to stick to that standard unless you can come up with a good/valid reason against doing so? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- We have this line at the top of the script: 43 use C4::Overdues qw(GetFine GetOverdueMessageTransportTypes); I think adding the new routine the same way would be more consistent. Can you please provide a new patch? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #5 from Marc Véron <veron@veron.ch> --- (In reply to Martin Renvoize from comment #3)
QA Style note, we tend to import routines over adding full namespaces..
(...) There is one more full name space in line 323: my @overduebranches = C4::Overdues::GetBranchcodesWithOverdueRules(); I think this should be fixed as well to be consistent. Ah, is it necessary that the subs are exported in C4/Overdues.pm? Line 47 following: GetBranchcodesWithOverdueRules is not listed -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #6 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Oh man we're inconsistent in this script :(. Well spotted Marc, reading C4::Overdues I note it's using EXPORT instead of EXPORT_OK too :(. Personally, I believe if a routine is intended to be used in another module it should appears in the EXPORT_OK block not the EXPORT block, and that it should be explicitly imported into the using module with a use statement. So.. if I were being picky I'd say.. convert the EXPORT to EXPORT_OK (but this may break modules that expect to have access to the routines without explicitly importing them :( ), add the routine your found to the EXPORT_OK block also, and then clean up here to match. Perhaps split the work into two bugs.. one clean up and one just fixing the initial bug.. thoughts? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #7 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- s/this script/these scripts/ -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I think best to fix the one problem identified here ... and do general cleanup separately :) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #9 from Marc Véron <veron@veron.ch> --- (In reply to Katrin Fischer from comment #8)
I think best to fix the one problem identified here ... and do general cleanup separately :)
+1 :-) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #45115|0 |1 is obsolete| | --- Comment #10 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 45124 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=45124&action=edit Bug 15242 - Missing subroutine in overdue_notices.pl This patch changes the call to parse_overdues_letter to use the full namespace to ensure the subroutine can be found. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #45124|0 |1 is obsolete| | --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 45137 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=45137&action=edit [SIGNED OFF] Bug 15242 - Missing subroutine in overdue_notices.pl This patch changes the call to parse_overdues_letter to use the full namespace to ensure the subroutine can be found. Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #45137|0 |1 is obsolete| | --- Comment #12 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 45144 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=45144&action=edit Bug 15242 - Missing subroutine in overdue_notices.pl This patch changes the call to parse_overdues_letter to use the full namespace to ensure the subroutine can be found. Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |12933 See Also|http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=12933 | CC| |jonathan.druart@bugs.koha-c | |ommunity.org Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12933 [Bug 12933] Add ability to print overdue slip from staff intranet -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 --- Comment #13 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Martin Renvoize from comment #3)
QA Style note, we tend to import routines over adding full namespaces..
I'd prefer to stick to that standard unless you can come up with a good/valid reason against doing so?
And I prefer the other way :) I personally think it adds readability and eases refactoring. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15242 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |tomascohen@gmail.com --- Comment #14 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patch pushed to master. Thanks Nick! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org