[Bug 41116] New: Selectors are inconsistently structured in hold found modals
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Bug ID: 41116 Summary: Selectors are inconsistently structured in hold found modals Initiative type: --- Sponsorship --- status: Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff interface Assignee: koha-bugs@lists.koha-community.org Reporter: andrew@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com The hold found modals (#hold-found-modal for not-yet-waiting holds, #hold-found1 for holds already at Waiting status) have clear selectors for most parts of the patron contact info, but the patron's phone number doesn't get any class or id of its own and the patron's email has an id that excludes the bullet point. That makes these two values harder to hide or style with CSS. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |andrew@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #1 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- Created attachment 188517 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188517&action=edit Bug 41116: Standardize selectors in patron contact information in hold found modals This patch modifies both hold-found-modal and hold-found1. It adds a class to the patron phone number. For patron email, it changes the existing id to a class, expands the selector to include the bullet point in hold-found-modal, and standardizes the name (changing from "#boreamil' to ".patronemail"). To test: 1 - have a patron with both a phone number and an email address 2 - create a hold for your patron 3 - check an item in to fill your hold, triggering the hold-found-modal 4 - inspect the patron contact info, confirm there is no class on the phone number 5 - confirm there is an id on the patron email but it does not include the bullet point and is inconsistent with the names of other classes in the modal 6 - click Confirm Hold 7 - check your item in again, triggering the hold-found1 modal 8 - confirm there is no class on the patron phone number 9 - confirm there is an id on the patron email with an inconsistent name 10 - revert the waiting status of your hold 11 - apply patch, restart_all 12 - check your item in again, triggering hold-found-modal 13 - confirm the patron phone now has a class, .patronphone 14 - confirm the patron email now has a class, .patronemail, that the class includes the bullet point, and that the #boremail id has been removed 15 - click Confirm Hold 16 - check your item in again, triggering hold-found1 modal 17 - confirm the patron phone now has a class, .patronphone 18 - confirm the patron email now has a class, .patronemail, and that the #boremail id has been removed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #188517|0 |1 is obsolete| | --- Comment #2 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 189849 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=189849&action=edit Bug 41116: Standardize selectors in patron contact information in hold found modals This patch modifies both hold-found-modal and hold-found1. It adds a class to the patron phone number. For patron email, it changes the existing id to a class, expands the selector to include the bullet point in hold-found-modal, and standardizes the name (changing from "#boreamil' to ".patronemail"). To test: 1 - have a patron with both a phone number and an email address 2 - create a hold for your patron 3 - check an item in to fill your hold, triggering the hold-found-modal 4 - inspect the patron contact info, confirm there is no class on the phone number 5 - confirm there is an id on the patron email but it does not include the bullet point and is inconsistent with the names of other classes in the modal 6 - click Confirm Hold 7 - check your item in again, triggering the hold-found1 modal 8 - confirm there is no class on the patron phone number 9 - confirm there is an id on the patron email with an inconsistent name 10 - revert the waiting status of your hold 11 - apply patch, restart_all 12 - check your item in again, triggering hold-found-modal 13 - confirm the patron phone now has a class, .patronphone 14 - confirm the patron email now has a class, .patronemail, that the class includes the bullet point, and that the #boremail id has been removed 15 - click Confirm Hold 16 - check your item in again, triggering hold-found1 modal 17 - confirm the patron phone now has a class, .patronphone 18 - confirm the patron email now has a class, .patronemail, and that the #boremail id has been removed Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #3 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 189850 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=189850&action=edit Bug 41116: (follow-up) Some more fixes for consistency - There was a mix of "patronphone" and "patron-phone" and I fixed it to standardize on "patron-phone" (and patron-email) which I find easier to read. - I made similar changes to the branchtransfers template - Corrected the TT filter on mailto links from "html" to "uri" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #4 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- (In reply to Owen Leonard from comment #3)
Created attachment 189850 [details] [review] Bug 41116: (follow-up) Some more fixes for consistency
- There was a mix of "patronphone" and "patron-phone" and I fixed it to standardize on "patron-phone" (and patron-email) which I find easier to read. - I made similar changes to the branchtransfers template - Corrected the TT filter on mailto links from "html" to "uri"
Thanks, Owen! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA CC| |david@davidnind.com --- Comment #5 from David Nind <david@davidnind.com> --- The patch still applies, but I've failed QA. There is a %40 for the @ symbol in the hold found form, and in the HTML source for the hold found and hold found (item is already waiting). Hold found pop-up window ------------------------ Email address is shown on the form as: mary%40example.com (previously it was mary@example.com) - HTML <a href="mailto:mary%40example.com">mary%40example.com</a> Before the patch the HTML was <a id="boremail" href="mailto:mary@example.com">mary@example.com</a> Hold found (item is already waiting) ------------------------------------ - Email address is shown correctly, but in the HTML it is <a href="mailto:mary%40example.com">mary@example.com</a> - Before the patch it was <a id="boremail" href="mailto:mary@example.com">mary@example.com</a> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #6 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 194354 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=194354&action=edit Bug 41116: (follow-up) Fix template variable filter -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #7 from Owen Leonard <oleonard@myacpl.org> --- I saw one thing to correct, but otherwise the changes look right to me. A template variable inside a link's href attribute should have the "uri" filter and outside of that should have the "html" filter. In my testing the mailto: link work correctly (correctly populating the "to" field in a new email) even if they look wrong in the source. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #189849|0 |1 is obsolete| | --- Comment #8 from David Nind <david@davidnind.com> --- Created attachment 194360 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=194360&action=edit Bug 41116: Standardize selectors in patron contact information in hold found modals This patch modifies both hold-found-modal and hold-found1. It adds a class to the patron phone number. For patron email, it changes the existing id to a class, expands the selector to include the bullet point in hold-found-modal, and standardizes the name (changing from "#boreamil' to ".patronemail"). To test: 1 - have a patron with both a phone number and an email address 2 - create a hold for your patron 3 - check an item in to fill your hold, triggering the hold-found-modal 4 - inspect the patron contact info, confirm there is no class on the phone number 5 - confirm there is an id on the patron email but it does not include the bullet point and is inconsistent with the names of other classes in the modal 6 - click Confirm Hold 7 - check your item in again, triggering the hold-found1 modal 8 - confirm there is no class on the patron phone number 9 - confirm there is an id on the patron email with an inconsistent name 10 - revert the waiting status of your hold 11 - apply patch, restart_all 12 - check your item in again, triggering hold-found-modal 13 - confirm the patron phone now has a class, .patronphone 14 - confirm the patron email now has a class, .patronemail, that the class includes the bullet point, and that the #boremail id has been removed 15 - click Confirm Hold 16 - check your item in again, triggering hold-found1 modal 17 - confirm the patron phone now has a class, .patronphone 18 - confirm the patron email now has a class, .patronemail, and that the #boremail id has been removed Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #189850|0 |1 is obsolete| | --- Comment #9 from David Nind <david@davidnind.com> --- Created attachment 194361 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=194361&action=edit Bug 41116: (follow-up) Some more fixes for consistency - There was a mix of "patronphone" and "patron-phone" and I fixed it to standardize on "patron-phone" (and patron-email) which I find easier to read. - I made similar changes to the branchtransfers template - Corrected the TT filter on mailto links from "html" to "uri" Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #194354|0 |1 is obsolete| | --- Comment #10 from David Nind <david@davidnind.com> --- Created attachment 194362 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=194362&action=edit Bug 41116: (follow-up) Fix template variable filter Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #11 from David Nind <david@davidnind.com> --- (In reply to Owen Leonard from comment #7)
I saw one thing to correct, but otherwise the changes look right to me. A template variable inside a link's href attribute should have the "uri" filter and outside of that should have the "html" filter. In my testing the mailto: link work correctly (correctly populating the "to" field in a new email) even if they look wrong in the source.
Thanks Owen! For another bug, but the details on the patron's page probably need to be updated at some stage so they are the same (the sidebar, and the information on the details page). David -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Laura Escamilla <Laura.escamilla@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA QA Contact|testopia@bugs.koha-communit |Laura.escamilla@bywatersolu |y.org |tions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Laura Escamilla <Laura.escamilla@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #194360|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Laura Escamilla <Laura.escamilla@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #194361|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 Laura Escamilla <Laura.escamilla@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #194362|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #12 from Laura Escamilla <Laura.escamilla@bywatersolutions.com> --- Created attachment 200594 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200594&action=edit Bug 41116: Standardize selectors in patron contact information in hold found modals This patch modifies both hold-found-modal and hold-found1. It adds a class to the patron phone number. For patron email, it changes the existing id to a class, expands the selector to include the bullet point in hold-found-modal, and standardizes the name (changing from "#boreamil' to ".patronemail"). To test: 1 - have a patron with both a phone number and an email address 2 - create a hold for your patron 3 - check an item in to fill your hold, triggering the hold-found-modal 4 - inspect the patron contact info, confirm there is no class on the phone number 5 - confirm there is an id on the patron email but it does not include the bullet point and is inconsistent with the names of other classes in the modal 6 - click Confirm Hold 7 - check your item in again, triggering the hold-found1 modal 8 - confirm there is no class on the patron phone number 9 - confirm there is an id on the patron email with an inconsistent name 10 - revert the waiting status of your hold 11 - apply patch, restart_all 12 - check your item in again, triggering hold-found-modal 13 - confirm the patron phone now has a class, .patronphone 14 - confirm the patron email now has a class, .patronemail, that the class includes the bullet point, and that the #boremail id has been removed 15 - click Confirm Hold 16 - check your item in again, triggering hold-found1 modal 17 - confirm the patron phone now has a class, .patronphone 18 - confirm the patron email now has a class, .patronemail, and that the #boremail id has been removed Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Laura_Escamilla <laura.escamilla@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #13 from Laura Escamilla <Laura.escamilla@bywatersolutions.com> --- Created attachment 200595 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200595&action=edit Bug 41116: (follow-up) Some more fixes for consistency - There was a mix of "patronphone" and "patron-phone" and I fixed it to standardize on "patron-phone" (and patron-email) which I find easier to read. - I made similar changes to the branchtransfers template - Corrected the TT filter on mailto links from "html" to "uri" Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Laura_Escamilla <laura.escamilla@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41116 --- Comment #14 from Laura Escamilla <Laura.escamilla@bywatersolutions.com> --- Created attachment 200596 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200596&action=edit Bug 41116: (follow-up) Fix template variable filter Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Laura_Escamilla <laura.escamilla@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org