[Bug 15629] New: Move the C4::Branch related code to Koha::Libraries - part 3
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 Bug ID: 15629 Summary: Move the C4::Branch related code to Koha::Libraries - part 3 Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: ASSIGNED Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: jonathan.druart@bugs.koha-community.org Reporter: jonathan.druart@bugs.koha-community.org QA Contact: testopia@bugs.koha-community.org Depends on: 15628 Blocks: 15293 Part 1 (bug 15294) and part 2 (bug 15295) have been pushed. This third part will remove some C4::Branch subroutines: - GetBranchesInCategory - GetBranchDetail - ModBranch - GetBranchInfo Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15293 [Bug 15293] Move the C4::Branch related code to Koha::Libraries http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15628 [Bug 15628] Remove get_branchinfos_of vestiges -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #1 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46997 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46997&action=edit Bug 15629: Koha::Libraries - Remove GetBranchesInCategory (1) For consistency, the branchcodes method of Koha::LibraryCategory should be named libraries. At the moment, there is only one occurrence, in admin/branches.pl -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #2 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46998 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46998&action=edit Bug 15629: Koha::Libraries - Remove GetBranchesInCategory (2) C4::Branch::GetBranchesInCategory can be replaced with Koha::LibraryCategory->libraries Test plan: 1/ Define some 1+ group of libraries with 1+ libraries each 2/ Go on the advanced search (OPAC and Staff) and select a group of libraries 3/ The result should be consistent and only include record from these libraries -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #3 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 46999 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=46999&action=edit Bug 15629: Koha::Libraries - Remove GetBranchesInCategory (3) C4::Branch::GetBranchesInCategory is not used anymore and can be removed. Test plan: git grep GetBranchesInCategory should not return any result. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #4 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 47000 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=47000&action=edit Bug 15629: Koha::Libraries - Remove GetBranchDetail C4::Branch::GetBranchDetail retrieved library infos, it could be easily replaced with Koha::Libraries->find When this change needs other big changes, the unblessed method is called, to manipulate a hashref (as before) instead of a Koha::Library object (for instance when $library is sent to GetPreparedLetter). Test plan: 1/ Print a basket group, the library names should be correctly displayed. 2/ Enable emailLibrarianWhenHoldIsPlaced and place a hold, a HOLDPLACED notice will be generated (focus on the library name) 3/ Edit a patron and change his/her library 4/ Generate the advanced notices (misc/cronjobs/advance_notices.pl) and have a look at the generated notices 5/ Same of overdues notices 6/ Set IndependentBranches and use a non superlibrarian user to place a hold. The "pickup at" should be correctly filled. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #5 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 47001 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=47001&action=edit Bug 15629: Koha::Libraries - Remove ModBranch This subroutine was only used in tests to add/update a library. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15629 --- Comment #6 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 47002 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=47002&action=edit Bug 15629: Koha::Libraries - Remove GetBranchInfo C4::Branch::GetBranchInfo was only used once in opac/opac-suggestions.pl The occurrence can easily be replaced by a call to Koha::Libraries->find Test plan: 1/ Create a suggestion for library A 2/ Enable OPACViewOthersSuggestions 3/ Use a patron from library B to see the suggestions 4/ The "Suggested for" value should be correctly filled with the library A name. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org