[Bug 29180] New: System preference RequestOnOpac should be renamed
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Bug ID: 29180 Summary: System preference RequestOnOpac should be renamed Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: System Administration Assignee: koha-bugs@lists.koha-community.org Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com It is a confusing name because we have 'Article Request' as a feature, and this does not follow Koha terminology Possibly, 'AllowHoldsOnOpac'? -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |2334 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=2334 [Bug 2334] noOPACHolds syspref unused, superceded by RequestOnOpac -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |andrew@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #1 from Owen Leonard <oleonard@myacpl.org> --- (In reply to Nick Clemens from comment #0)
Possibly, 'AllowHoldsOnOpac'?
+1 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Hm, I suggest AllowOpacHolds - but yes, took me ages to remember that one... -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com --- Comment #3 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- OPACHoldRequests? (don't we usually prefix OPAC sysprefs by 'OPAC'?) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Jonathan Druart from comment #3)
OPACHoldRequests? (don't we usually prefix OPAC sysprefs by 'OPAC'?)
+1 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #5 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 127318 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127318&action=edit Bug 29180: Rename syspref RequestOnOpac with OPACHoldRequests It is a confusing name because we have 'Article Request' as a feature, and this does not follow Koha terminology. Test plan: `updatedatabase` and confirm that the syspref has been renamed `git grep RequestOnOpac` => No occurrence in the code QA: The syspref's value is always retrieved using Koha.Preference from .tt files, we don't need to send it from controllers or C4::Auth -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |jonathan.druart+koha@gmail. |ity.org |com Keywords| |rel_21_11_candidate -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #127318|0 |1 is obsolete| | --- Comment #6 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- Created attachment 127324 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127324&action=edit Bug 29180: Rename syspref RequestOnOpac with OPACHoldRequests It is a confusing name because we have 'Article Request' as a feature, and this does not follow Koha terminology. Test plan: `updatedatabase` and confirm that the syspref has been renamed `git grep RequestOnOpac` => No occurrence in the code QA: The syspref's value is always retrieved using Koha.Preference from .tt files, we don't need to send it from controllers or C4::Auth Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #127324|0 |1 is obsolete| | --- Comment #7 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 127351 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127351&action=edit Bug 29180: Rename syspref RequestOnOpac with OPACHoldRequests It is a confusing name because we have 'Article Request' as a feature, and this does not follow Koha terminology. Test plan: `updatedatabase` and confirm that the syspref has been renamed `git grep RequestOnOpac` => No occurrence in the code QA: The syspref's value is always retrieved using Koha.Preference from .tt files, we don't need to send it from controllers or C4::Auth Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com> Signed-off-by: Nick Clemens <nick@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #8 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 127352 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127352&action=edit Bug 29180: (QA follow-up) Alphabetize sysprefs.sql Signed-off-by: Nick Clemens <nick@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #9 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 127353 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=127353&action=edit Bug 29180: (QA follow-up) Don't alter old DB up date Signed-off-by: Nick Clemens <nick@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |nick@bywatersolutions.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #10 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Thanks Nick, good catches! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |21.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #11 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Pushed to master for 21.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|rel_21_11_candidate | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |release-notes-needed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |System preference release notes| |RequestOnOpac renamed to | |OPACHoldRequests. It could | |be confused with the | |'Article Request' feature | |and does not follow Koha | |terminology - OPAC related | |system preferences normally | |start with OPAC. CC| |david@davidnind.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|release-notes-needed |Manual -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED CC| |kyle@bywatersolutions.com Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 Aude Charillon <aude.charillon@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |aude.charillon@ptfs-europe. | |com Keywords|Manual |Manual-updated -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29180 --- Comment #12 from Aude Charillon <aude.charillon@ptfs-europe.com> --- Changes for this bug are now incorporated in the manual. Here are the changes made: renamed system preference RequestOnOpac to OPACHoldRequests in OPAC preferences, OPAC and Implementation checklist (see https://gitlab.com/koha-community/koha-manual/-/commit/f669393bf840c9e0b0a4c...) -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org