[Bug 33191] New: AutoEmailPrimaryAddress options don't match labels in memberentry
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Bug ID: 33191 Summary: AutoEmailPrimaryAddress options don't match labels in memberentry Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff interface Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com This preference is confusing as the options it contains don't all match the labels for the corresponding fields in the member entry forms. * 'work'.. this corresponds to 'Secondary email' * 'home'.. this corresponds to 'Primary email' * 'alternate'.. ? We should either hint what these fields 'mean' on the form or update the systempreference options to match the existing form field label? -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |Academy -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com, | |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=29046 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=33192 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #1 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Here is the corresponding field names Current syspref choices | DB field | Field name in patronfields.inc ------------------------+----------+------------------------------- home | email | Primary email ------------------------+----------+------------------------------- work | emailpro | Secondary email ------------------------+----------+------------------------------- alternate | B_email | Alternate email -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |String patch -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #2 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Created attachment 148098 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148098&action=edit Bug 33191: AutoEmailPrimaryAddress options don't match labels in memberentry This patch changes the wording for the AutoEmailPrimaryAddress system preference to make it clearer. To test: 1. Go to Administration > Global system preferences 2. Search for AutoEmailPrimaryAddress 3. Read the sentence and choices, make sure it makes sense, grammar and spelling are correct 4. Click the link to AutoEmailNewUser, it should bring up the correct system preference 5. Optionally, try the different options, they should work as before -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #3 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- I submitted something. It only changes the wording of the preference. If you'd prefer the modal like BorrowerMandatoryField for example, that's a bit outside my knowledge, but I guess I could do some copy-paste and figure it out :) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Thanks Caroline, the select options change is perfect. You've fallen into the same trap I did however regards linking the preference to AutoEmailNewUser.. in actual fact, this preference isn't that closely related to that preference, it applies to a lot more notices than just the welcome one. I've actually opened a bug to rename this pref and also to expand it with yet another preference to govern the order of the 'first valid' option from here. I'll take a deeper look on Monday with the aim of signing off. :) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #5 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Ok, maybe this bug should be the last in the series to be corrected then? 1st bug 33192 2nd bug 29046 3rd this -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |29046 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29046 [Bug 29046] Allow libraries to specify email order for "AutoEmailPrimaryAddress" -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |18398 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18398 [Bug 18398] CHECKIN/CHECKOUT/RENEWAL don't use AutoEmailPrimaryAddress but first valid e-mail -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #6 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- We may as well add in bug 18398 to the little tree that's building here too.. Perhaps we should also look at updateing the uses of first_valid_email listed above to also use notice_email_address as another bug in this set? -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=18398 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|18398, 29046 |33192 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18398 [Bug 18398] CHECKIN/CHECKOUT/RENEWAL don't use AutoEmailPrimaryAddress but first valid e-mail https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29046 [Bug 29046] Allow libraries to specify email order for "AutoEmailPrimaryAddress" https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 [Bug 33192] We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148098|0 |1 is obsolete| | --- Comment #7 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Created attachment 148141 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148141&action=edit Bug 33191: AutoEmailPrimaryAddress options don't match labels in memberentry This patch changes the wording for the EmailFieldPrimary system preference to make it clearer. To test: 1. Go to Administration > Global system preferences 2. Search for EmailFieldPrimary 3. Read the sentence and choices, make sure it makes sense, grammar and spelling are correct 4. Optionally, try the different options, they should work as before -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #8 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Redid the choices on top of the name change (bug 33192) -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |This enhancement changes release notes| |the wording of the choices | |in the EmailFieldPrimary | |system preference (formely | |AutoEmailPrimaryAddress) to | |match the patron form field | |names. | |The choices were | |changed like so: | |- 'home' | |is now called 'primary | |email' and refers to the | |email database column | |- | |'work' is now called | |'secondary email' and | |refers to the emailpro | |database column | |- | |'alternate' is still called | |'alternate email' and | |refers to the B_email | |database column | |- first | |valid and cardnumber did | |not change. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148141|0 |1 is obsolete| | --- Comment #9 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 148156 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148156&action=edit Bug 33191: AutoEmailPrimaryAddress options don't match labels in memberentry This patch changes the wording for the EmailFieldPrimary system preference to make it clearer. To test: 1. Go to Administration > Global system preferences 2. Search for EmailFieldPrimary 3. Read the sentence and choices, make sure it makes sense, grammar and spelling are correct 4. Optionally, try the different options, they should work as before Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #10 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Excellent, I think this all starts to become a lot more clear now :) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |caroline.cyr-la-rose@inlibr |ity.org |o.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |minor -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148156|0 |1 is obsolete| | --- Comment #11 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 149640 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=149640&action=edit Bug 33191: AutoEmailPrimaryAddress options don't match labels in memberentry This patch changes the wording for the EmailFieldPrimary system preference to make it clearer. To test: 1. Go to Administration > Global system preferences 2. Search for EmailFieldPrimary 3. Read the sentence and choices, make sure it makes sense, grammar and spelling are correct 4. Optionally, try the different options, they should work as before Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | CC| |m.de.rooy@rijksmuseum.nl -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |23.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 --- Comment #12 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.05. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED Status|Pushed to master |RESOLVED CC| |matt.blenkinsop@ptfs-europe | |.com --- Comment #13 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Not backporting to 22.11.x as bug 33192 is an enhancement and has not been backported Nice work everyone! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au --- Comment #14 from David Cook <dcook@prosentient.com.au> --- I still wish that we'd done a better shift from home/work to primary/secondary overall. So many libraries use work/secondary emails as the most important email and Koha has made things so confusing over the years. Bug 18398, Bug 33223 and Bug 29046 go a long way to improving things. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 Bug 33191 depends on bug 33192, which changed state. Bug 33192 Summary: We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org