[Bug 33282] New: Cypress tests are failing
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Bug ID: 33282 Summary: Cypress tests are failing Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Test Suite Assignee: chris@bigballofwax.co.nz Reporter: pedro.amorim@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: jonathan.druart+koha@gmail.com, martin.renvoize@ptfs-europe.com, tomascohen@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #1 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 148427 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148427&action=edit Bug 33282: Rename Dialog.spec.ts to Dialog_spec.ts -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #2 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 148428 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148428&action=edit Bug 33282: Remove redundant intercept -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #3 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 148429 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148429&action=edit Bug 33282: Move get_title to index.js to be invoked by different specs -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #4 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 148430 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148430&action=edit Bug 33282: Feed an array of titles so that no dialog message appears, including but not limited to the one we're testing for -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #5 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- This is not done yet, there's something weird happening with Packages_specs.ts. It doesn't fail running cypress open, but sometimes fails running cypress through CLI (headless), it's hard to pinpoint because it doesn't always fail. I think it's something to do with the loading dialog modal. Following the tests in the browser, the "Loading..." dialog modal is always present, and it seems to sometimes block a click() in Packages_specs.ts. Instead of just adding {force:true} to the click(), I'm trying to figure out why "Loading..." modal never stops showing with Cypress on the browser, but haven't figured it out yet. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #6 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Pedro Amorim from comment #5)
This is not done yet, there's something weird happening with Packages_specs.ts. It doesn't fail running cypress open, but sometimes fails running cypress through CLI (headless), it's hard to pinpoint because it doesn't always fail.
I think it's something to do with the loading dialog modal. Following the tests in the browser, the "Loading..." dialog modal is always present, and it seems to sometimes block a click() in Packages_specs.ts. Instead of just adding {force:true} to the click(), I'm trying to figure out why "Loading..." modal never stops showing with Cypress on the browser, but haven't figured it out yet.
Weird! I've noticed a JS/DT error: "(alert) Something went wrong when loading the table. 200: OK." This is not expected. But it appears even when the tests pass. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148427|0 |1 is obsolete| | Attachment #148428|0 |1 is obsolete| | Attachment #148429|0 |1 is obsolete| | Attachment #148430|0 |1 is obsolete| | --- Comment #7 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 148509 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148509&action=edit Bug 33282: Rename Dialog.spec.ts to Dialog_spec.ts Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #8 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 148510 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148510&action=edit Bug 33282: Remove useless intercept JD amended patch: replace "redundant" with "useless". It's not the same intercept, but we don't need the one removed by this patch. Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #9 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 148511 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148511&action=edit Bug 33282: Move get_title to index.js to be invoked by different specs Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #10 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 148512 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148512&action=edit Bug 33282: Feed an array of titles so that no dialog message appears, including but not limited to the one we're testing for Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|chris@bigballofwax.co.nz |pedro.amorim@ptfs-europe.co | |m --- Comment #11 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- I've got the failure once (using cypress open), then no more. I think we should move forward with these patches, and fix the random failure separately. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=32898, | |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=33235 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148512|0 |1 is obsolete| | --- Comment #12 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 148631 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148631&action=edit Bug 33282: Feed an array of titles so that no dialog message appears Including but not limited to the one we're testing for Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |23.05.00 released in| | --- Comment #13 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Pushed to master for 23.05. We want jenkins happy to start the hackfest :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #14 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Final follow-up pushed to 22.11.x for 22.11.04 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #15 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- oop.. wrong bug!.. ignore that.. this one is still in the queue -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |Pushed to stable Version(s)|23.05.00 |23.05.00,22.11.04 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 --- Comment #16 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Many hands makes light work, thankyou everyone! Pushed to 22.11.x for the next release -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33282 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED Status|Pushed to stable |RESOLVED CC| |lucas@bywatersolutions.com --- Comment #17 from Lucas Gass <lucas@bywatersolutions.com> --- Not needed in 22.05.x, no backport. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org