[Bug 34575] New: Patron search results: Customise the fields displayed in Name column
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Bug ID: 34575 Summary: Patron search results: Customise the fields displayed in Name column Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Patrons Assignee: koha-bugs@lists.koha-community.org Reporter: sally.healey@cheshiresharedservices.gov.uk QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com Since the staff interface redesign, the search patron results table is prone to breaking the width of the screen, causing a horizontal scrollbar to display. The Name column displays the following content: Patron name Patron address Email address The column is flexible, because the filter is a search. As there are spaces in the name/address content, the column can be a very small width on smaller monitors. But the email address is often very long - and this causes the Name column to be very wide. On our system, two of our own council email address domains are 30 characters in length - that's before you've added the prefix, so email addresses can easily be 50+ characters, making for a very wide column. Is it possible to create a setting where we can choose not to include the email address in the search results? -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Sally <sally.healey@cheshiresharedservices.gov.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=34574 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |pedro.amorim@ptfs-europe.co | |m --- Comment #1 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 160207 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=160207&action=edit Demo patron long e-mail Hi Sally, I've added an attachment with a patron in the table with an e-mail address of 50 characters. At a glance, the table looks okay. Please note that in this screenshot I have bug 34574 applied, i.e. the issue with the library and patron categories column does not happen here. Are you able to confirm if this still requires looking into? Or are you able to provide a new/different example? Thank you! -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 --- Comment #2 from Sally <sally.healey@cheshiresharedservices.gov.uk> --- (In reply to Pedro Amorim from comment #1)
Created attachment 160207 [details] Demo patron long e-mail
Hi Sally, I've added an attachment with a patron in the table with an e-mail address of 50 characters.
At a glance, the table looks okay. Please note that in this screenshot I have bug 34574 applied, i.e. the issue with the library and patron categories column does not happen here.
Are you able to confirm if this still requires looking into? Or are you able to provide a new/different example?
Thank you!
Hi Pedro, It's still an issue for us. As a simple solution, could we just add a class to email? For Henry in the test data, this is what's in the table: <div class="address"> <ul> <li class="patronaddress1"> 4345 Library Rd. </li> <li class="patroncity">Springfield, MA 44224</li> <li>Email: <a href="mailto:example@test.com">example@test.com</a> </li> </ul> </div> Note that address1 and city both have classes, but email doesn't. If a class was added to email, as it is for the other address lines: <div class="address"> <ul> <li class="patronaddress1"> 4345 Library Rd. </li> <li class="patroncity">Springfield, MA 44224</li> <li class="patronemail">Email: <a href="mailto:example@test.com">example@test.com</a> </li> </ul> </div> Then I can just hide it with CSS - and nobody else is affected by the change? What do you think? -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |35629 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35629 [Bug 35629] Redundant code in includes/patron-search.inc -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 --- Comment #3 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 160229 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=160229&action=edit Bug 34575: Add a CSS class to patron email Adds a CSS class to the patron email section in the 'name-address' column of search results in members-home.pl No functional behaviour change. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 --- Comment #4 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- (In reply to Sally from comment #2)
Hi Pedro,
It's still an issue for us.
As a simple solution, could we just add a class to email?
I love this suggestion, submitted the patch, new HTML should now be: <ul> <li class="patronaddress1">31 4345 Library Rd. </li> <li class="patroncity">City in address zip postal, test</li> <li class="patronemail">Email: <a href="mailto:randomlongemailstringtobeusedasanexample%40koha.com">randomlongemailstringtobeusedasanexample@koha.com</a></li> </ul> Thank you. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Biblibre Sandboxes <sandboxes@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #160229|0 |1 is obsolete| | --- Comment #5 from Biblibre Sandboxes <sandboxes@biblibre.com> --- Created attachment 160264 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=160264&action=edit Bug 34575: Add a CSS class to patron email Adds a CSS class to the patron email section in the 'name-address' column of search results in members-home.pl No functional behaviour change. Signed-off-by: Sally <sally.healey@cheshiresharedservices.gov.uk> -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Sally <sally.healey@cheshiresharedservices.gov.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off --- Comment #6 from Sally <sally.healey@cheshiresharedservices.gov.uk> --- Brilliant, thanks so much, Pedro - exactly what I needed! :) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |pedro.amorim@ptfs-europe.co |ity.org |m -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Katie Bliss <kebliss@dmpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kebliss@dmpl.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |oleonard@myacpl.org, | |victor@tuxayo.net -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Victor Grousset/tuxayo <victor@tuxayo.net> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |victor@tuxayo.net |y.org | Summary|Patron search results: |Patron search results: Add |Customise the fields |a CSS class to patron email |displayed in Name column |to ease customization --- Comment #7 from Victor Grousset/tuxayo <victor@tuxayo.net> --- Tried to rename the ticket, feel free to improve if I misunderstood. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 --- Comment #8 from Victor Grousset/tuxayo <victor@tuxayo.net> --- We have classes like patron_name and patroncity. If the style is already inconsistent, let's go for the more readable one for new classes. So patron_email. Patch amended. Feel free to comment if that doesn't look like a good change. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Victor Grousset/tuxayo <victor@tuxayo.net> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #160264|0 |1 is obsolete| | --- Comment #9 from Victor Grousset/tuxayo <victor@tuxayo.net> --- Created attachment 162854 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=162854&action=edit Bug 34575: Add a CSS class to patron email Adds a CSS class to the patron email section in the 'name-address' column of search results in members-home.pl No functional behaviour change. Signed-off-by: Sally <sally.healey@cheshiresharedservices.gov.uk> Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Victor Grousset/tuxayo <victor@tuxayo.net> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA --- Comment #10 from Victor Grousset/tuxayo <victor@tuxayo.net> --- Works, makes sense, QA script happy, code looks good, passing QA :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to main Version(s)| |24.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Pushed for 24.05! Well done everyone, thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to main |Pushed to stable CC| |fridolin.somers@biblibre.co | |m Version(s)|24.05.00 |24.05.00,23.11.06 released in| | --- Comment #12 from Fridolin Somers <fridolin.somers@biblibre.com> --- Small useful enhancement, Pushed to 23.11.x for 23.11.06 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to stable |RESOLVED CC| |lucas@bywatersolutions.com Resolution|--- |FIXED --- Comment #13 from Lucas Gass <lucas@bywatersolutions.com> --- Enhancement will not be backported to 23.05.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34575 Bug 34575 depends on bug 35629, which changed state. Bug 35629 Summary: Redundant code in includes/patron-search.inc https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35629 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to oldstable |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org