[Bug 16870] New: Koha::Issue(s) should be named Koha::Checkout(s)
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Bug ID: 16870 Summary: Koha::Issue(s) should be named Koha::Checkout(s) Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Circulation Assignee: koha-bugs@lists.koha-community.org Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com By our naming guidelines, the term "issue" is deprecated in favor of "checkout". We should update the class names to match. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |16086 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16086 [Bug 16086] Add Koha::Issue objects. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |6906 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6906 [Bug 6906] show 'Borrower has previously issued $ITEM' alert on checkout -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |6906 Blocks|6906 | Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6906 [Bug 6906] show 'Borrower has previously issued $ITEM' alert on checkout -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |kyle@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 --- Comment #1 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53188 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53188&action=edit Bug 16870 - Move and rename class files and unit tests -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 --- Comment #2 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53189 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53189&action=edit Bug 16870 - Update Koha::Patron use of the class Test Plan: 1) Apply this patch 2) prove t/db_dependent/Patron/Borrower_PrevCheckout.t 3) prove t/db_dependent/Koha/Checkouts.t -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Srdjan Jankovic <srdjan@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |srdjan@catalyst.net.nz --- Comment #3 from Srdjan Jankovic <srdjan@catalyst.net.nz> --- Kyle, Koha::Checkout(s) was added in 14757, patch 1 https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52924 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 --- Comment #4 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Srdjan Jankovic from comment #3)
Kyle, Koha::Checkout(s) was added in 14757, patch 1 https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=52924
Yes, I noticed that! I will need to modify this patch set to take that into account. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #53188|0 |1 is obsolete| | Attachment #53189|0 |1 is obsolete| | --- Comment #5 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53373 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53373&action=edit Bug 16870 - Move and rename class files and unit tests -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 --- Comment #6 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53374 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53374&action=edit Bug 16870 - Update Koha::Patron use of the class Test Plan: 1) Apply this patch 2) prove t/db_dependent/Patron/Borrower_PrevCheckout.t 3) prove t/db_dependent/Koha/Checkouts.t -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #53373|0 |1 is obsolete| | Attachment #53374|0 |1 is obsolete| | --- Comment #7 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53375 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53375&action=edit Bug 16870 - Move and rename class files and unit tests -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 --- Comment #8 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 53376 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53376&action=edit Bug 16870 - Update Koha::Patron use of the class Test Plan: 1) Apply this patch 2) prove t/db_dependent/Patron/Borrower_PrevCheckout.t 3) prove t/db_dependent/Koha/Checkouts.t -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Srdjan Jankovic <srdjan@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #53375|0 |1 is obsolete| | --- Comment #9 from Srdjan Jankovic <srdjan@catalyst.net.nz> --- Created attachment 53407 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53407&action=edit [SIGNED-OFF] Bug 16870 - Move and rename class files and unit tests Signed-off-by: Srdjan <srdjan@catalyst.net.nz> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Srdjan Jankovic <srdjan@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Srdjan Jankovic <srdjan@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #53376|0 |1 is obsolete| | --- Comment #10 from Srdjan Jankovic <srdjan@catalyst.net.nz> --- Created attachment 53408 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=53408&action=edit [SIGNED-OFF] Bug 16870 - Update Koha::Patron use of the class Test Plan: 1) Apply this patch 2) prove t/db_dependent/Patron/Borrower_PrevCheckout.t 3) prove t/db_dependent/Koha/Checkouts.t Signed-off-by: Srdjan <srdjan@catalyst.net.nz> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Should not we rename OldIssue[s] as well? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |In Discussion -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=17796 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16870 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |RESOLVED Resolution|--- |DUPLICATE --- Comment #12 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- *** This bug has been marked as a duplicate of bug 17796 *** -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org