[Bug 41842] New: Improve translation of course reserves headings
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Bug ID: 41842 Summary: Improve translation of course reserves headings Initiative type: --- Sponsorship --- status: Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: I18N/L10N Assignee: oleonard@myacpl.org Reporter: oleonard@myacpl.org QA Contact: testopia@bugs.koha-community.org CC: f.demians@tamil.fr, jonathan.druart@gmail.com Page title, headings, and legends could use some improvements to how they are translated, with more consistent use of context and placeholders -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Small patch Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #1 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 193145 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=193145&action=edit Bug 41842: Improve translation of course reserves headings This patch adds some use of I18N functions to course reserves templates in order to improve the process of translation by adding context and placeholders. The patch also rewords some headings for clarity and consistency. To test, apply the patch and go to course reserves. - Add a course if necessary. - Click the course to view it. - On the course details page, confirm that the page title, breadcrumbs, and heading look correct. - Click "Edit" in the toolbar. - Check the page title, breadcrumbs, and heading again. - Return to the course details and click "Add reserves" and check that page. - Submit a barcode or biblionumber and check that page. - Test the "Batch add reserves" page. To test the improved I18N, apply the patch and test that the correct strings are translatable. In this example I'm testing fr-FR: - Update a translation: > gulp po:update > cd misc/translator > perl translate update fr-FR - Open the corresponding .po file for the modified strings, e.g. fr-FR-messages.po. - Locate strings pulled from course reserves templates for translation, e.g.: #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:10 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:42 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:56 #, fuzzy, perl-brace-format msgid "Edit course {course_name}" msgstr "Modifier {course_name}" - Remove the "fuzzy," - Edit the "msgstr" string however you want (it's just for testing) - Install the updated translation:
perl translate install fr-FR
Switch to the translation you updated. Walk through the process of editing a course and adding course reserves to confirm that your translated strings show up. Sponsored-by: Athens County Public Libraries -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |jonathan.druart@gmail.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Comma delimited| |Athens County Public list of Sponsors| |Libraries Sponsorship status|--- |Sponsored Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #193145|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #2 from David Nind <david@davidnind.com> --- Created attachment 199322 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=199322&action=edit Bug 41842: Improve translation of course reserves headings This patch adds some use of I18N functions to course reserves templates in order to improve the process of translation by adding context and placeholders. The patch also rewords some headings for clarity and consistency. To test, apply the patch and go to course reserves. - Add a course if necessary. - Click the course to view it. - On the course details page, confirm that the page title, breadcrumbs, and heading look correct. - Click "Edit" in the toolbar. - Check the page title, breadcrumbs, and heading again. - Return to the course details and click "Add reserves" and check that page. - Submit a barcode or biblionumber and check that page. - Test the "Batch add reserves" page. To test the improved I18N, apply the patch and test that the correct strings are translatable. In this example I'm testing fr-FR: - Update a translation: > gulp po:update > cd misc/translator > perl translate update fr-FR - Open the corresponding .po file for the modified strings, e.g. fr-FR-messages.po. - Locate strings pulled from course reserves templates for translation, e.g.: #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:10 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:42 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:56 #, fuzzy, perl-brace-format msgid "Edit course {course_name}" msgstr "Modifier {course_name}" - Remove the "fuzzy," - Edit the "msgstr" string however you want (it's just for testing) - Install the updated translation:
perl translate install fr-FR
Switch to the translation you updated. Walk through the process of editing a course and adding course reserves to confirm that your translated strings show up. Sponsored-by: Athens County Public Libraries Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #3 from David Nind <david@davidnind.com> --- Testing notes (using KTD): 1. fuzzy terms for translation are in po/fr-FR-staff-prog.po and po/fr-FR-messages.po One suggestion for the batch add reserves page: - Change form title from "Add items: scan barcodes" to "Add items by barcode", to match batch remove reserves page Some of the differences I noted (I probably missed some) ======================================================== Course details page: - Page title: course name italicised Edit course details page: - Breadcrumb, Page title, Tab title: Now begins with "Edit course XYZ", instead of "Edit XYZ" - Adds "Edit course" in the section with the white background above the form, and under the page title ("Edit course XYZ") Add reserves page: - Page title is now "Add reserves for course XYZ", instead of "Add reserves for XYZ" - After entering the barcode: . page title, breadcrumb and tab title is now "Adding item for course XYZ" (previously it was "ReserveABC for XYZ" (no space after reserve, ABC = title of item, XYZ = course name) . form title is now "Adding ABC", previously it was "Add ABC to XYZ" (where ABC = item title, and XYZ = course name) Batch add reserves page: - Page title is now "Add reserves for course XYZ" instead of "Add reserves for XYZ" Batch remove reserves: - Form title is now "Remove items by barcode" instead of "Remove items: scan barcodes" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |42099 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42099 [Bug 42099] Update course reserve pages to use grid layout for forms -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #4 from David Nind <david@davidnind.com> --- Note: this also fixes up how the section field value is shown as part of the course name in the page title, breadcrumb and page heading: - Before (space after the hyphen): Course name- Section A - After (no space before or after the hyphen): Course name-Section A -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #5 from Jonathan Druart <jonathan.druart@gmail.com> --- - <span>Edit [% course_name | html | $HtmlTags tag="em" %][%- IF course.section -%]- [% course.section | html | $HtmlTags tag="em" %][%- END -%]</span> + [% tx("Edit course {course_name}", { course_name = course_name }) | $raw %] Why did you remove the section from this one? Shouldn't it be + [% tx("Edit course {course_name}", { course_name = course_em }) | $raw %] like everywhere else? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #6 from Jonathan Druart <jonathan.druart@gmail.com> --- (In reply to Jonathan Druart from comment #5)
- <span>Edit [% course_name | html | $HtmlTags tag="em" %][%- IF course.section -%]- [% course.section | html | $HtmlTags tag="em" %][%- END -%]</span> + [% tx("Edit course {course_name}", { course_name = course_name }) | $raw %]
Why did you remove the section from this one?
Shouldn't it be + [% tx("Edit course {course_name}", { course_name = course_em }) | $raw %] like everywhere else?
It's the one from breadcrumb: https://snipboard.io/xKyPLG.jpg -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=42654 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |42654 CC| |martin.renvoize@openfifth.c | |o.uk Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42654 [Bug 42654] Regression: Section missing from OPAC course reserve detail page -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA QA Contact|jonathan.druart@gmail.com |martin.renvoize@openfifth.c | |o.uk -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #199322|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #7 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 200972 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200972&action=edit Bug 41842: Improve translation of course reserves headings This patch adds some use of I18N functions to course reserves templates in order to improve the process of translation by adding context and placeholders. The patch also rewords some headings for clarity and consistency. To test, apply the patch and go to course reserves. - Add a course if necessary. - Click the course to view it. - On the course details page, confirm that the page title, breadcrumbs, and heading look correct. - Click "Edit" in the toolbar. - Check the page title, breadcrumbs, and heading again. - Return to the course details and click "Add reserves" and check that page. - Submit a barcode or biblionumber and check that page. - Test the "Batch add reserves" page. To test the improved I18N, apply the patch and test that the correct strings are translatable. In this example I'm testing fr-FR: - Update a translation: > gulp po:update > cd misc/translator > perl translate update fr-FR - Open the corresponding .po file for the modified strings, e.g. fr-FR-messages.po. - Locate strings pulled from course reserves templates for translation, e.g.: #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:10 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:42 #: koha-tmpl/intranet-tmpl/prog/en/modules/course_reserves/course.tt:56 #, fuzzy, perl-brace-format msgid "Edit course {course_name}" msgstr "Modifier {course_name}" - Remove the "fuzzy," - Edit the "msgstr" string however you want (it's just for testing) - Install the updated translation:
perl translate install fr-FR
Switch to the translation you updated. Walk through the process of editing a course and adding course reserves to confirm that your translated strings show up. Sponsored-by: Athens County Public Libraries Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Martin Renvoize <martin.renvoize@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #8 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 200973 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200973&action=edit Bug 41842: Use space-dash-space separator between course name and section The staff interface templates were using a bare hyphen with no spaces when displaying course name and section together, while the OPAC templates (Bug 42654) use ' - ' (space-dash-space). This brings the staff interface into alignment with the OPAC convention for consistency and readability. Signed-off-by: Martin Renvoize <martin.renvoize@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #9 from Jonathan Druart <jonathan.druart@gmail.com> --- Owen, can you confirm that adding spaces is ok for you? See also bug 42654. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #200973|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #10 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 200976 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200976&action=edit Bug 41842: Use space-dash-space separator between course name and section The staff interface templates were using a bare hyphen with no spaces when displaying course name and section together, while the OPAC templates (Bug 42654) use ' - ' (space-dash-space). This brings the staff interface into alignment with the OPAC convention for consistency and readability. Signed-off-by: Martin Renvoize <martin.renvoize@openfifth.co.uk> Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41842 --- Comment #11 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 200977 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=200977&action=edit Bug 41842: (follow-up) Make sure this space doesn't get tidied Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org